LIGHTROOM cannot delete keywords from multiple photos

  • 1
  • Problem
  • Updated 5 years ago
  • (Edited)
I was disappointed to see that the bug of removing keywords from multiple photos has NOT been fixed in LR5.2RC. Specifically, when multiple photos are selected in the Library mode, and a keyword is right-clicked and then the option "Remove keyword from selected photos" is selected, the keyword is removed only from the most selected photo. I use keywords a lot, and this bugs me! Please fix--it can't be difficult.
Photo of Bogdan Oporowski

Bogdan Oporowski

  • 4 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 1
Photo of Rikk Flohr

Rikk Flohr, Champion

  • 1373 Posts
  • 336 Reply Likes
This only works in photos in Grid mode. If you are in Loupe, Compare or Survey in Library and select items via the Film Strip only the "most" selected or active image is affected.

What mode were you in?
Photo of Bogdan Oporowski

Bogdan Oporowski

  • 4 Posts
  • 0 Reply Likes
Thanks for your reply!

You are right--it does work in Grid mode. However, I have two monitors, and my secondary monitor always displays the grid, so I am never formally in Grid mode, as this would only duplicate the display of my other monitor. It make little sense to me to have to switch to the Grid mode only to be able to delete keywords. Note the following:

1. "Add this keyword to selected photos" works in all modes, exactly as I want it to. I would like "Delete..." to behave the same way.

2. Even if there is some reason not to change the behavior of "Delete this keyword from selected photos" when in modes other than Grid, then the text of the menu should be changed from "photos" to "photo".

Thoughts?