Cannot update Lightroom from 6.2 to 6.3 on Mac running MacOS 10.11 El Capitan

  • 1
  • Problem
  • Updated 11 months ago
  • (Edited)
Yesterday, I tried to update my 6.2 version of Lightroom to the latest version 6.3.

I am running the latest version of El Capitan on my Mac Pro.

In my first attempt to update, I used the Creative Cloud process, which clearly indicated that an update was available for Lightroom.

I chose update and hoped for the best. The best did not happen. When I opened Lightroom it was still version 6.2.

Then I tried a recommendation by Lightroom expert Laura Shoe for downloading the update directly and clicked on the link she included for a Mac download. What downloaded was a setup.dmg file, not the full Lightroom update file. I ran this file but, sadly, this also did not work.

Then I tried refreshing the update process by logging out of Adobe Creative Cloud and logging back in.

This also did not work.

What will work?
Photo of Ry Glover

Ry Glover

  • 4 Posts
  • 6 Reply Likes
  • angry

Posted 3 years ago

  • 1
Photo of Bea Estrada

Bea Estrada

  • 1 Post
  • 0 Reply Likes
I have the same issue today on my Mac deskstop IOS Sierra 10.12.6 cannot update