Elements 13: Cannot synchronise photo albums in iTunes after upgrading from Elements 11

  • 3
  • Problem
  • Updated 7 months ago
  • Solved
  • (Edited)
After upgrading from photoshop elements 11 to 13 I cannot synchronise photo albums to my ipad via itunes. The albums made in elements 13 never show up. After converting the catalog the old catalog was renamed by photoshop. When I change the name of the old catalog directory back into the original name, I see the albums of Element 11 in Itunes. How should I solve this problem?
Photo of Joop de Jong

Joop de Jong

  • 6 Posts
  • 3 Reply Likes

Posted 4 years ago

  • 3
Photo of Joop de Jong

Joop de Jong

  • 6 Posts
  • 3 Reply Likes
I hope that the problem will be solved (perhaps in the next Itunes update). For the time being I have the following workaround:
In the windows register I changed the value of Elements Organizer 11.0 CurrentCatalogpath sothat it's pointing to the elements 13 catalog directory.
In the elements 13 directory I made a symbolic link named catalog.pse11db, pointing to catalog.pse13db. Now I can sync the elements 13 albums.

However, I did not yet uninstall elements 11. While studying the new program I sometimes want to look back to the old situation, in which case I have to alter the windows register again.
Photo of Andre Podleisek

Andre Podleisek

  • 2 Posts
  • 2 Reply Likes
I am having the same problem, upgrading from PSE12 to PSE13.
It seems to me that after converting the catalogue to version 13 the new folder it is placed into is not recognized by iTunes. Also PSE13 is not recognized by iTunes, it still uses the previous version/folder.
This may have been solved by Joop by changing the registry path entry of PSE11.

However, since I uninstalled PSE12, this no longer works for me. I have moved the old catalogues from the PSE catalogue directory (C:\ProgramData\Adobe\Elements Organizer\Catalogs) to an external drive. Now iTunes no longer recognizes any albums, the only option active on the foto sync page is "sync all albums", which results in no album being synced at all.

Another workaround I read about was to copy the new catalogue into the old folder (e.g. the one where the catalogue of PSE11 is located in) and rename it to the name of the old catalogue file. Backdraw of this solution vs. the one of Joop is you need to copy the file each time you made an update of your new catalogue and want to synchronize albums in iTunes. In my case this didn't work, the iTunes Sync went into an endless "updating (6/6)".

Uninstalling and Re-installing iTunes does not solve the problem, because iTunes retains all the setting from the previous installation (which usually is a good thing, but not in this case).

Any ideas?
Photo of Joop de Jong

Joop de Jong

  • 6 Posts
  • 3 Reply Likes
I suppose that after uninstalling elements the entry in the windows registry is still there. You could search with regedit for Elements Organizer and then 12.0. Then change the value of CurrentCatalogPath.
Another possibility is perhaps deleting (or renaming) the elements 12 directory and make a symbolic link pointing to the elements 13 catalog directory. Look here how to create a symbolic link
Photo of Andre Podleisek

Andre Podleisek

  • 2 Posts
  • 2 Reply Likes
You are right, when I searched the registry for "CurrentCatalogPath" I discovered all registry entries starting from version 9.0 were still there. I am wondering which one iTunes used, probably the one which was there the first time iTunes was installed. Since the directories of the versions prior to 13 are not existing anymore, I changed all of the entries to the catalogue of version 13.

Many thanks for the great symbolic link feature, very helpful also for other issues!

PS: We seem to be both old school, as we use "directory" instead of "folder" ;-)
Photo of andaleeb

andaleeb, Employee

  • 157 Posts
  • 21 Reply Likes
Hi,

Please update to latest version of iTunes (12.1.2.27) and see if the issue is fixed for you.

Thanks
Andaleeb
Photo of Joop de Jong

Joop de Jong

  • 6 Posts
  • 3 Reply Likes
Yes, this update solved the problem
Photo of John Bengtson

John Bengtson

  • 1 Post
  • 0 Reply Likes
Solved it for me as well, thanks.
Photo of Rob

Rob

  • 1 Post
  • 1 Reply Like
Has this feature ever worked from a Mac? I was able to sync my photos from Windows Elements to Apple TV, but not when I moved to the Mac. I'm not sure if this is an iTunes issues or simply not available on the Mac version.

Thanks!
Photo of Jack Klaber

Jack Klaber

  • 143 Posts
  • 22 Reply Likes
Had this problem with my iPhone 7+ with iOS 11.3 since I updated iTunes from 11.6 to 11.7 and later.
A few chats with Apple iTunes support and Internet searches brought me to the solution that iTunes version 11.6.2.20 is compatible with the later iOS version and still let you copy photos from PSE to your iPhone using the Album tag!
If you have a later iTunes version than the said 11.6.2.20 version, uninstall it and then download it from f.i. https://www.filehorse.com/download-itunes-64/old-versions/ .
HTH.....