Lightroom Classic: Cannot send email with gmail 2-step security

  • 1
  • Problem
  • Updated 2 months ago
  • Solved
  • (Edited)
I cannot send emails from Lightroom Classic CC on my iMac unless I turn off 2-step verification in Google. I just finished spending an hour and ten minutes with Deepak Singh of Adobe Support trying to make it work [case number ADB-3082886-N3Z8]. He was heroic, but there is apparently no way to send a photo from Lightroom without compromising the security of my Google applications. This is an issue Adobe needs to address--YESTERDAY.
Photo of Neil Gallagher

Neil Gallagher

  • 3 Posts
  • 0 Reply Likes
  • frustrated and quite dissatisfied

Posted 2 months ago

  • 1
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4327 Posts
  • 1582 Reply Likes
You should be able to create an app-specific password in Gmail https://support.google.com/accounts/answer/185833?hl=en so you can leave 2-step turned on.
Photo of Neil Gallagher

Neil Gallagher

  • 3 Posts
  • 0 Reply Likes
Thank you very much, Victoria. I saw this, and did it, but got the same result. I spent over an hour with the Adobe rep, who put me on hold several times while he consulted with others. Shutting off the 2-step security was the only thing that allowed me to email. I chose not to do that.

I have also tried this with my icloud email address, which also requires creating an app-specific password. I got a similar message: Validation Failed. Cannot establish a secure channel with the outgoing email server smtp.mail.me.com.

This appears to be an Adobe bug, which I think they should fix, rather than telling users to compromise their Google security.
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4327 Posts
  • 1582 Reply Likes
I've just tested Lightroom Classic 7.4 on macOS 10.13.6 and gone through the whole rigmarole - turned on 2FA in Gmail, had to log back into my normal email software, then created an app-specific password in Gmail and used that to set up email in Lightroom. I then emailed myself a photo from Lightroom using that account, and received it at the other address.

I'm a glutton for punishment, so I then did my iCloud account for good measure, as that also has 2FA enabled. That one failed on SSL, but validated as STARTTLS.

So, app-specific passwords do work in Lightroom 7.4. Perhaps check you're using that version, under Help menu > System Info?
Photo of Neil Gallagher

Neil Gallagher

  • 3 Posts
  • 0 Reply Likes
Woo Hoo! I switched the iCloud entry to STARTTLS, and it worked like a charm. As long as I can send from there I don't care about Gmail.

Thank you! You are not only the Lightroom Queen, you are the Fairy Godmother of Lightroom Email.
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4262 Posts
  • 1544 Reply Likes
Happy to help Neil!