Photoshop: Cannot put text in custom shape - 10 pointed star

  • 1
  • Problem
  • Updated 2 years ago
  • (Edited)
Text inside shapes is no longer working in my Photoshop! It does not matter that the shape layer IS selected and it is indeed a shape, the text tool does not show the icon for putting text into a shape, it shows a normal text tool and the usual manual drag for size. It does not automatically fit to the shape! It does not show the rounded text icon when I hover over a shape.

I Googled the problem but nothing came up! There is no information regarding being unable to put text into shapes! I am using Photoshop CC 2018. It worked before and now it is not working!

 I tried a different shape and it is working on that shape! However, it will not work on the shape that I need it to work on, the 10 pointed star!

Any shape I create, it works on, but many of the default shapes it does not work on! The only post I see about this was ages ago regarding the very first Photoshop CC version. There is literally nothing regarding this problem on CC 2018

Edit: I zoomed in as far as it will go (3200x) and went around the entire shape and the shape is definitely closed. The other really old topic does not apply in this case
Photo of Justin Coolidge

Justin Coolidge

  • 48 Posts
  • 2 Reply Likes
  • frustrated

Posted 2 years ago

  • 1
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 16505 Posts
  • 2659 Reply Likes
Can you post a file with your shape for us to try and troubleshoot?
Photo of David

David, Official Rep

  • 3435 Posts
  • 572 Reply Likes
Howdy Jeffrey,

I'm not seeing a problem on either Windows or Mac with the latest release.  Are you still seeing this problem?  What OS and version of Photoshop are you using?