Photoshop CC 2015: Cannot set Photoshop as default program in "open with"

  • 5
  • Problem
  • Updated 7 months ago
  • Solved
  • (Edited)
I cannot open an image directly into photoshop CC 2015 by right clicking. PS CC 2015 does not show as a default program in the list. I've gone into browse and tried to add it by going to Adobe, Adobe photoshop 2015, choosing the program file, but nothing. Bridge shows up as does lightroom 2014 (refusing at this point to download the new one until there is a fix for this. Finally today it shows up as a program in the control panel default programs list, so it should show up as a program set to open jpg or whatever files but PSCC2015 is not available. I have jpg set to open with photo gallery but I should be able to right click and get PSCC2015. I cannot set.png file association to open with PSCC 2015 but it will open with Bridge. PSCC2015 is in the default list but not when choosing default programs. HELP! About ready to toss it and go back to 2014!
A clue may be that each time I launch photoshop or bridge it asks if I want to allow this program to make a change on my hard drive!
Photo of Karen Wood

Karen Wood

  • 5 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 5
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15366 Posts
  • 2241 Reply Likes
We're working on a fix for this in a future update.

In the meantime, try this solution: https://helpx.adobe.com/photoshop/kb/...
Photo of Cindy McCravey

Cindy McCravey

  • 4 Posts
  • 3 Reply Likes
I tried this and the desktop CC app only opens the 2014 which I thought had been removed... I do not find Anything in the drop down that says install and there isn't anything about 2015 in that previous versions...
Photo of Winona Schultz Scribner

Winona Schultz Scribner

  • 1 Post
  • 0 Reply Likes
I am having the same issue, and I use Photoshop constantly at work. Please tell me how to correct!
Photo of Karen Wood

Karen Wood

  • 5 Posts
  • 0 Reply Likes
Winona I got one problem solved by putting a .png on the desktop and a .jpg on the desktop and then pulling them over the PS icon and right clicking which then allowed me to associate PS as the default program. Now it shows up in my list when I right click. BUT, I still haven't solved the problem of it asking, before each and every image or png opens, if I want PS to make changes to my hard drive, which tells me something is still not right! But its better.
Photo of Chris Cox

Chris Cox

  • 1 Post
  • 2 Reply Likes
Well after some digging I was able to fix this problem on my install of CC 2015. There is a spot in the registry that apparently didn't get updated correctly upon install of CC 2015. I went to HKEY_CLASSES_ROOT > Photoshop.exe > shell > open > command. The only entry there for me said ""C:\Program Files\Adobe\Adobe Photoshop CC 2014\Photoshop.exe" "%1"". I changed the 2014 to a 2015 and now right clicking on a .jpg file gives Photoshop 2015 CC as an option. Hope this helps anyone.
Photo of Aileen Panganiban

Aileen Panganiban

  • 1 Post
  • 0 Reply Likes
It works for me, thanks Chris
Photo of Robert Razgoršek

Robert Razgoršek

  • 1 Post
  • 0 Reply Likes
Works for me also
Photo of Gregory Batchelor

Gregory Batchelor

  • 3 Posts
  • 3 Reply Likes
Karen, THANKS! Your fix worked for me and was so simple. To recap:

1. Open Photoshop

2. Drag any jpg to the PS button on button bar to pin it

3. Right-click a jpg and select Open With > Choose Default Program

Photoshop should now be one of the options to select.
Photo of Abhi Sharma

Abhi Sharma

  • 1 Post
  • 0 Reply Likes
Thanks man. It work for me.
Photo of Deb Bonham

Deb Bonham

  • 1 Post
  • 0 Reply Likes
Yes! Works for me...thanks
Photo of Paula Sanders

Paula Sanders

  • 3 Posts
  • 1 Reply Like
I was able to change the path. Now I can open using Photoshop CC 2015 in window Photo viewer jpg, but Bridge still looks for Photoshop 2014 even though I have removed it. I have done a bunch of registry searches, but can't find a way to fix the Bridge.
Photo of Paula Sanders

Paula Sanders

  • 3 Posts
  • 1 Reply Like
Solved both issues. In Adobe Bridge go to pref>file associations. Then on psd, click on down arrow and change it to Photoshop 2015.
Photo of John Erickson

John Erickson

  • 2 Posts
  • 0 Reply Likes
This is ALWAYS a problem. Now as of 2 months ago we're waiting on a fix in a future update that apparently still hasn't happened? Come ON. Every single time I update anything Adobe, I have to deal with stupid unfixable file association problems. How hard can it be to fix this issue?
Photo of John Erickson

John Erickson

  • 2 Posts
  • 0 Reply Likes
BTW, I followed all the steps here. When I right click on a jpeg and select "choose default program," I have to navigate through Windows to Photoshop and then "always use this program to open this type of file" is greyed out. So I'm reduced to right clicking and picking Photoshop every single time.
Photo of Paula Sanders

Paula Sanders

  • 3 Posts
  • 1 Reply Like
I found the solution and posted an article about a month ago.

http://www.perpetualvisions.com/new-a...

It fixed the issues I was having.
Photo of Peter Whitmer

Peter Whitmer

  • 1 Post
  • 0 Reply Likes
This fix mentioned at the top addressed my issue in Window 7. Might be different in other windows versions.

One note -- I only had the key "open", which was set to 2014. I changed that, and added edit, and it now I can right-click on jpgs and open PS.

Thanks!
Photo of Mark Niebauer

Mark Niebauer

  • 1 Post
  • 0 Reply Likes
control panel - Default programs - Set your default programs - Photoshop does not show up on the list and the bridge is not linking up with photoshop either. None of the above suggestions worked? Any ideas out there?
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15366 Posts
  • 2241 Reply Likes
Official Response
This was fixed a while back on Windows. Please let us know if you're still having trouble.
Photo of Melony Price Rhodes, PhD

Melony Price Rhodes, PhD

  • 1 Post
  • 0 Reply Likes
I cannot get PS 2015.5 to open from LR, right click, edit in, this is no longer a choice. 2018 is the only PS choice. Windows, 7 Home Premium, Service Pack 1 ASUS G750JZ, 64-bit.
Photo of Farnia Ghavami

Farnia Ghavami

  • 1 Post
  • 0 Reply Likes
I am still having this problem with Photoshop 2018. I cannot get it to become part of the recommended programs, I keep going into browse, I pick the .exe file and nothing happens. I have reinstalled and installed many times using Adobe Cloud and still have this issue as many above. What is the fix on Windows? 
Photo of Mike Martin

Mike Martin

  • 1 Post
  • 0 Reply Likes
I am having the same problem.
(Edited)
Photo of Swan Lin

Swan Lin

  • 1 Post
  • 0 Reply Likes
I am having the same problem with Photoshop Elements 2018.  Cannot set PSE to "Always use this app to open JPG files" as the default in Open With.  In Windows settings > Choose  Default Apps by File Type, same problem.  In both File Explorer and Windows setting, PSE is shown in the list of programs.  However choosing it does not set the program as default.  Instead, JPG files are opening in Paint 3D.  Very annoying!  Don't know if this is a bug in Windows or in Photoshop???