Lightroom Classic: Cannot delete Collections, or move images between them

  • 1
  • Problem
  • Updated 10 months ago
  • (Edited)
First time trying to do new work using LR 7.2 since upgrade, previously it has rebooted my PC when running the Duplicates II plugin (which had run successfully just before the upgrade ...!). I do NOT like the thought that things can get so messed up that I get a reboot, especially on a system that usually stays running 24/7!

Anyway - the problem: When in the Library, went to Collections and decided I would simplify a collection that tracks what images I've printed, from numbered sub-collections to simple Printed / Not yet Printed collections (I'm tracking the numbers/sizes etc. in a spreadsheet now). However, when I tried to delete some empty catalogs they didn't disappear, whether I use the right-click & delete or the hyphen at the top of the collections area.

Then, I found I couldn't copy images between collections. I haven't delved further yet, but this is the first time something like this has happened for me since I started with the LR 1 beta.
Photo of Gary Rowe

Gary Rowe

  • 98 Posts
  • 36 Reply Likes
  • annoyed at the lack of regression testing by Adobe

Posted 10 months ago

  • 1
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 1591 Posts
  • 642 Reply Likes
Could it be that this 'Duplicates II' plugin is damaging your catalog because it is no longer compatible? Each new version of Lightroom upgrades the catalog database, so a plugin that creates collections (and I assume that is what this plugin does as well) might cause problems if it was not tested and updated for Lightroom Classic. It's easy to blame Adobe for this, but I do not experience any of the problems you mentioned.
(Edited)
Photo of Gary Rowe

Gary Rowe

  • 98 Posts
  • 36 Reply Likes
Hi Johan, Certainly something weird happened. After a bit of printing of other images, when I tried again it is now working normally with & within collections. Phew. I'll monitor it for the next few days I work in LR.