Photoshop Elements: PSE Editor 10 crashes on launch

  • 1
  • Problem
  • Updated 6 years ago
  • (Edited)
I have Photoshop Elements 10. The editor will NOT load, it tries and crashes. The organizer works just fine, but this does not allow me to access the features of the software that I need. I've been searing through all kinds of forms with all types of random suggestions but nothing seems to be resolving the issue. (windows xp sp3 operating system)
Photo of Erin Fontaine

Erin Fontaine

  • 3 Posts
  • 0 Reply Likes
  • frustrated

Posted 6 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 812 Reply Likes
What OS version?

What does the crash report say?
Photo of Erin Fontaine

Erin Fontaine

  • 3 Posts
  • 0 Reply Likes
windows xp (service pack 3)

it doesn't give an error report of any kind, it tries to load but will not open.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 812 Reply Likes
OK, if it crashed you would get a message about the app terminating.

So what exactly is happening when you try to launch the editor?
Photo of Erin Fontaine

Erin Fontaine

  • 3 Posts
  • 0 Reply Likes
I click on Editor from the welcome screen (or from inside of the organizer which works fine) and a small box pops up that says "Loading the Photoshop Elements Editor workspace" the bar moves along the bottom again and again as if it's working to open for maybe about a minute.. and then it freezes... locks up... (not sure the proper way to describe it) and that little box goes away and the Editor does not open, no error message, no reason why it won't load or open. I've tried uninstalling the entire program and reinstalling, same thing happens.
Photo of Brett N

Brett N, Official Rep

  • 2258 Posts
  • 114 Reply Likes
Has the Editor ever launched on this computer?

Try launching the Editor directly (not from the Welcome Screen or from the Organizer). Use My Computer to go to C:\Program Files\Adobe\Photoshop Elements 10\. Look for PhotoshopElementsEditor.exe and double-click it. Does this work? Does it give an error message? Do you see the splash screen?