Lightroom: Can I configure to always delete the master file?

  • 1
  • Question
  • Updated 5 years ago
  • Answered
  • (Edited)

If I want to delete a file, I don't just remove it from the cataloge, but to delete the master file, too.

If I use the remove key, I get the (annoying) pop up, what I want to do: (sorry, I've a german version, so I just try to translate it)

Delete from hard disk
Remove (default selected)

Is there any chance to avoid this dialog? Or at least to chance the preselected button, so I've just to use the enter key?

Actually I've to

press delete
press left arrow key
press enter

That is a little bit annoying and error-prone

Thanks a lot!
Photo of Michael Decker

Michael Decker

  • 38 Posts
  • 0 Reply Likes
  • sad

Posted 5 years ago

  • 1
Photo of jdv

jdv, Champion

  • 728 Posts
  • 56 Reply Likes
This behaviour is, of course, completely by design. However, the best way to delete artefacts is to just mark them as rejects and then purge later.

As you've or with the catalogue mark this items you want removed with "x" and just move on. Most filters will now ignore the item, and most views will show them greyed out, if they show them at all.

Some time later when you are doing catalogue maintenance use the menu item to purge rejects all at once. If the entire catalogue I'd made active first, you will be able to purge all rejects with one confirmation.
Photo of Rob Cole

Rob Cole

  • 4831 Posts
  • 386 Reply Likes
Ctrl-Shift-Alt-Delete is what I use.
On Mac: Cmd-Shift-Option-Delete