Camera Raw: Auto black and white

  • 1
  • Problem
  • Updated 4 years ago
  • Solved
  • (Edited)
I would like to use Camera Raw to set the black and white points automatically. I know this can be done by holding the shift key and doubleclicking on the sliders to set just those values.
But when I do this in an image that has a black shirt in it the black point setting is really dark. In fact it's the same value as if I would have used auto-values for all basic settings. And I do not want auto for all settings, I still want the shirt to be black, not grey. Is there a way to do this?
I have a reference black and white in the image.
Photo of Urpo Finnilä

Urpo Finnilä

  • 10 Posts
  • 1 Reply Like

Posted 4 years ago

  • 1
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2589 Posts
  • 323 Reply Likes
The shift-double-click Auto respects the crop box, so you can crop down to just the reference you want to use and shift-double-click and then adjust or remove the cropbox.
Photo of Urpo Finnilä

Urpo Finnilä

  • 10 Posts
  • 1 Reply Like
Tried that just now, doesn't work. The blacks still get too dark. I tried several locations for the crop box. Not just the black reference. No change in value for the auto black.
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2589 Posts
  • 323 Reply Likes
The auto-black I'm talking about is shift-double-click not just the auto button above all the toning sliders that sets all the values, and will choose different values for the black and white points.

I am working on an image, right now, with a black squirrel, and a sun-bleached wood fence. If I click the Auto tone button above the sliders the black slider is set to -39. If I set a small crop-box to include just the fence I get an auto-black of -100. If I put it on a shaded area of the black squirrel I get an auto-black of -31. If I remove the cropbox entirely and do an auto-black I get -48 for the overall picture.

And no matter where I put the crop box, the black-level computed by clicking the Auto toning button remains the same.

Using shift-auto-click will slightly clip the blacks within the cropbox and the histogram will show what is in the cropbox as well. Are you saying you want to blacks to be brighter than just clipped? Then you're not setting the black point, you're asking for nothing to be black in the photo. You can set the black point using shift-double-click then adjust the blacks slider up a bit.
Photo of Urpo Finnilä

Urpo Finnilä

  • 10 Posts
  • 1 Reply Like
That's the one I tried, shift-double-click on black slider. Same behaviour in both Camera raw 7 and 8. It sets black to whatever it would be as if I had clicked Auto.

If you want to try my file I can send it to you.
Photo of Urpo Finnilä

Urpo Finnilä

  • 10 Posts
  • 1 Reply Like
I tried using PS/Camera raw on another workstation. No problem, it behaves just as you describe Steve. Now, if I just can get IT to find out what's wrong with my workstation...
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2589 Posts
  • 323 Reply Likes
Are you using the same photo on both workstations?

Is 2012 set for the Process version in the Camera Calibration tab for the photo?
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2589 Posts
  • 323 Reply Likes
The new double-click behavior started with a particular version of ACR, so make sure you're using ACR 8.7 on the workstation you're seeing the issue with.

If you're not sure what version you're using then use

Help (on Windows) / About Plug-ins / Camera Raw in PS to find out.
Photo of Urpo Finnilä

Urpo Finnilä

  • 10 Posts
  • 1 Reply Like
Problem solved, my workstation had some updates that weren't installed. I'll go stand in the corner now... Thanks!