Lightroom: Bugs with video metadata status

  • 4
  • Problem
  • Updated 3 years ago
  • (Edited)
LR 5.2 is inconsistent in how it handles metadata status for videos.

The smart-collection and filter criterion Metadata Status value "Changed on disk" matches any video that hasn't had any metadata changes applied in the catalog. The status value "Conflict detected" matches any video that has keywords or caption applied. Regardless of whether metadata has been applied to the videos in the catalog, the Metadata pane shows "Metadata Status: Up to date" for all videos, and no metadata-status icon ever appears in the upper-right corner of video thumbnails in grid view.

The correct behavior for videos, given LR's current inability to read and write metadata to video files:

- If no metadata changes have been applied in the catalog: the Metadata pane, the grid thumbnail icon, and the smart-collection and filter criterion should all report "Up to date".

- If metadata changes have been applied in the catalog: the Metadata pane, the grid thumbnail icon, and the smart-collection and filter criterion should all report "Has been changed".
Photo of John R. Ellis

John R. Ellis, Champion

  • 3697 Posts
  • 968 Reply Likes

Posted 5 years ago

  • 4
Photo of Vienna

Vienna

  • 5 Posts
  • 2 Reply Likes
I am pretty sure that this didn't happen in LR 4. Unfortunately, have uninstalled all previous version, so I can't check it any more
Photo of John R. Ellis

John R. Ellis, Champion

  • 3697 Posts
  • 968 Reply Likes
I just checked LR 4.4 Windows 7 64-bit, and it has different buggy symptoms:

An freshly imported MP4 with no changes to catalog metadata matches status "Unknown". Whereas a freshly imported AVI matches status "Up to date".
Photo of Darren McGrandle

Darren McGrandle

  • 1 Post
  • 0 Reply Likes
Still an issue in LR5.7
Photo of John Ellis

John Ellis

  • 117 Posts
  • 12 Reply Likes
Bug still exists in LR 6.0.1 / OS X 10.10.3.