Lightroom mobile 2.8.1 for iOS: Edits are lost after saving to camera roll

  • 1
  • Problem
  • Updated 3 months ago
  • In Progress
  • (Edited)
I am very happy with the new lightroom update for iphone that has selective pen. It is great!

Here are the bugs of the latest (2.8.1) release:

1. When editing a picture and saving to the local filmroll on the phone, all edits are lost afterwards if one does not remember to press "force sync" before saving.
2. When using selective pen, the red area is gone if you want to edit the area afterwards.
3. When using selective pen, the whole area can be moved. However after moving it, alle further editing, like drawing more on the area happens on another place than where your finger is...

best regards,
Atle
Photo of Atle Silgjerd

Atle Silgjerd

  • 18 Posts
  • 0 Reply Likes
  • Happy, with issues

Posted 6 months ago

  • 1
Photo of Dave Pearce

Dave Pearce

  • 138 Posts
  • 33 Reply Likes
Cant say i have any of those issues on my 2 ipads and iPhone 6s.

Isnt 'force sync' to do with syncing to the cloud and nothing to do with how the files are saved locally?

Im assuming you are selecting the already masked area first before editing it, and you haven't got never show overlay turned on?
Photo of Atle Silgjerd

Atle Silgjerd

  • 18 Posts
  • 0 Reply Likes
Hi Dave,

Yes, this is a problem related to cloud saving. It has been like this for a while. It is reported before and tried to fix, but still some leftovers of this problem. When you use a lot of time to edit, it is not funny to loose it.

There are two choices for showing overlay. none of them shows my redmask.

best regards,
Atle
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 2920 Posts
  • 414 Reply Likes
Thanks for the feedback:

Regarding #3 - this is a known issue which will be fixed in an update.

Regarding #1 - We are unable to duplicate what you are seeing. Are you using Lightroom's Save to Camera Roll feature or are you using the Sharing button to access the iOS sharing options?
Photo of Dave Pearce

Dave Pearce

  • 138 Posts
  • 33 Reply Likes
Hi Atle.

I think i must be missing something.
When i edit my raw files on iPad the only time i have to save anything is when i save the JPG version with edits to the IOS camera roll. All other times i just close  LRM down. The raw files get transferred to my desktop LR with all edits intact when i have it open on my ipad, although it can take a while. Ive never had to use force sync or any type of save.

Ive just tried the local adjustment brush on my phone and i what i see is this. If i have applied a gradient overlay i have ot move it to get the red mask to show. If ive used the brush then  clicking on its relevant pin brings the mask up straight away.

During this time i also noticed the new edits i had done appeared on the same file in LR no my desktop, without me doing anything to get this to happen.

Dave.
Photo of Atle Silgjerd

Atle Silgjerd

  • 18 Posts
  • 0 Reply Likes
#1 I think it is better than it used to be, And I cannot find an easy receipt of how to do it. But it has happened to me several times on the latest version also. Maybe without wifi. I always prohibit syncing to cloud when I am without Wifi. When this happens, I normally do an edit, save the picture to the iphone with max resolution. When saving is ready, I quickly go to Instagram or whattsapp and post the picture. Then go back to lighroom there is no edit at all. Not even light adjustments. 

#2 I have selected "auto show red overlay" and the red mask never shows. When using the other gradient tool, the red mask shows correctly.

best regards,
Atle
Photo of Dave Pearce

Dave Pearce

  • 138 Posts
  • 33 Reply Likes
Just a side note. Its been pointed out in another thread (and ive confirmed it) that if you save at max resolution you always end up with the same size  image dimensions, even if you have heavily cropped. This means you aren't actually getting the max resolution/quality. This has nothing to do with your other issues, just thought id point this out.
Photo of Atle Silgjerd

Atle Silgjerd

  • 18 Posts
  • 0 Reply Likes
Hi Dave, No I have not seen that.
I only use Lightroom for iphone and seldom for the PC.

best regards,
Atle
Photo of Atle Silgjerd

Atle Silgjerd

  • 18 Posts
  • 0 Reply Likes
Hi guys,

Bug number 1 is still present in the latest lightroom app for iOS. When editing a pictuire and saving to camera roll without going back to the main menu in between makes it loose all edit. A still very annoying bug.
Photo of Melissa Rios

Melissa Rios, Lightroom Support Product Manager

  • 86 Posts
  • 19 Reply Likes
Hi Atle,

Can you confirm your version of Lightroom CC for mobile with a screenshot?

Can you also provide your steps to reproduce this issue in a list so we can attempt to reproduce?

Lastly, can you try to provide matching screenshots to each of those steps so we're clear where we should be looking?

Thanks for reporting this experience,
Melissa
Photo of Atle Silgjerd

Atle Silgjerd

  • 18 Posts
  • 0 Reply Likes
Hi Melissa, thank you for the quick reply.
Here is a bullet-proof method to trig the bug.
Please let me know if you need more info, but I dont think you need it:

1. Edit a photo.
2. Save the photo to the camera-roll
3. Stay in the picture and wait a little bit to check that no sync is going on.
3. exit the lightroom program
4. double-click to shut down lightroom abruptly
5. Open lightroom. 
6. The edit is lost.

The problem with the currect code:
----------------------------------------------
The edit is only saved in RAM and is uploaded to the cloud only when going back to picture-root or when doing a forced sync. Also if the user leaves the program there is a time-out in iOS that shuts unused programs and clears lightroom-RAM. 

Here is the solution:
-------------------------------
Save all changes locally in the NV-storage as the user edit the picture. Upload the changes to the cloud whenever there is time for it. Very simple.

What I normally do, is that I edit a picture, then save it on my camera roll, then exit the program to follow up on the picture, post it on IG or send it on mail. This is normal behaviour and this deletes my edit so its gone the next time I enter. Im pretty sure im not the only one having this behaviour.

Hope you fix it this time, good luck!

best regards,
Atle
Photo of Melissa Rios

Melissa Rios, Lightroom Support Product Manager

  • 86 Posts
  • 19 Reply Likes
Hey Atle,

I just attempted to reproduce the issue with your steps and still see the edit on the photo, not lost. Perhaps, I'm not doing this step correctly according to how you're doing it: 
"double-click to shut down lightroom abruptly".

Also, to replicate the "no sync" requirement - I turned on Airplane mode. I also turned off Use Cellular Data.

Are you able to provide those screenshots I mentioned previously? This would ensure I'm doing the exact same steps you're doing. Perhaps even a screen recording.

Also, were you able to confirm that you're on 3.0.1? What iPhone version do you have as well?

Thanks,
Melissa
Photo of Atle Silgjerd

Atle Silgjerd

  • 18 Posts
  • 0 Reply Likes
Hi, just upgraded my iphone 6 to latest iOS and checked lightroom is 3.0.1.
I will take some screenshots later.
I test this bug with a crop/resize.

Beat regards,
Atle
Photo of Melissa Rios

Melissa Rios, Lightroom Support Product Manager

  • 86 Posts
  • 19 Reply Likes
Hey Atle,

I think that was the missing detail. I was trying a preset and some exposure changes before. I just cropped and resized a photo and I can reproduce the behavior you're seeing.

I'll check with the team on this issue.

Thanks,
Melissa