Lightroom: GPS Data column disappears from Library Filter bar metadata browser returning from Map module

  • 2
  • Problem
  • Updated 2 months ago
  • (Edited)
[Update: The GPS Data Metadata browser column disappears when returning from Map to Library when there are more than four columns in the browser.  See this recipe from Louis Sherwin for reproducing the bug: 
https://feedback.photoshop.com/photoshop_family/topics/bug_report_filtering_for_metadata_gps_informa... 

Last tested in CC 2015.12 / OS X 10.12.6.  -- John R. Ellis]

Hej,I think I found a bug in LR 5.2 which can be reproduced as follows (my LR is german, so the english translations might be a little off of the actual labels):- go to library (Bibliothek) module- under library filter (Bibliotheksfilter) select meta data (Metadatan)- go all the way to the right and select add column (Spalte hinzufügen)- click none (ohne) and select GPS data (GPS-Daten)- go to map module- got back to library module- the newly created column is gone now.If you can or can't reproduce this or know a workaround, please let me know.Thanks, Tobi
Photo of Tobias Meyer

Tobias Meyer

  • 2 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 2
Photo of John R. Ellis

John R. Ellis, Champion

  • 3709 Posts
  • 970 Reply Likes
Unfortunately, I can't reproduce this in my LR 5.2 Windows 7 64-bit English configuration. When I go back from the Map module to the Library module, the GPS Data column is still present.
Photo of Tobias Meyer

Tobias Meyer

  • 2 Posts
  • 0 Reply Likes
John,

interesting to hear you don't have it. Your configuration is similar to mine (Win 7 64 bit), but with another language. I'd like to know what the difference is and what the problem is dependent on, but don't know how to compare our configurations in more detail.

Tobi
Photo of Louis Sherwin

Louis Sherwin

  • 139 Posts
  • 30 Reply Likes
The exact same thing is happening to me in LR 2017.9 but I have found that it only happens when you add a new column to the Library filter and select GPS Location. Then switching to the Map Module and back to Grid the column with GPS Location will be removed from the filter.

If your existing Filter has an unused column and you select GPS Location for that column it will stay in the filter when switching modules. However,  if you then add an additional column then the next time you switch modules the column that had the GPS Location will disappear.

Definitely a bug.

-louie
Photo of Michael Newman

Michael Newman

  • 5 Posts
  • 1 Reply Like
It's happening to me too. I'm on LR 6.12 and this happens every time I filter on "GPS Data" - "No Coordinates". I select one or more photos from those shown, I switch to the Map module and set the point on the map for the selected photos, then when I switch back to the Library module all the filters are in place EXCEPT for the GPS Data one. I have tried putting the GPS Data filter at the left hand end, at the right hand end, in the middle and in a new column. It makes no difference - it always fails.
Photo of John R. Ellis

John R. Ellis, Champion

  • 3676 Posts
  • 961 Reply Likes
Windows or Mac?  Could you provide a screen recording showing this?  I'm not able to reproduce this using the steps you and Louis have posted.  Having a reproducible recipe will make it much more likely Adobe will fix the bug.
Photo of Louis Sherwin

Louis Sherwin

  • 139 Posts
  • 30 Reply Likes
John,

1. Select any  source in Lightroom
2. In Grid select the "Default Columns"  Filter preset
3. From the context menu of any of the existing columns "Add Column"
4. Change the new column from "None" to "GPS Data"
5. Switch to Map Module (I use the mouse because I an never remember the keyboard shortcut.)
6. Switch back to Grid (G)

The new column for the "GPS Data" is gone. Every time. 

-louie
Photo of Louis Sherwin

Louis Sherwin

  • 139 Posts
  • 30 Reply Likes
MacOS 10.12.6 LightroomCC 2015.12
Photo of John R. Ellis

John R. Ellis, Champion

  • 3676 Posts
  • 961 Reply Likes
Excellent, that recipe reliably reproduces the bug on my system too.    Hopefully it will do the same for Adobe product developers.

Some experimentation indicates that the problem only occurs when there are more than four columns in the Metadata browser.  With four or less (including GPS Data) columns, the problem doesn't occur in my LR.

So a more precise workaround appears to be to avoid having more than four columns when using GPS Data.
Photo of John R. Ellis

John R. Ellis, Champion

  • 3676 Posts
  • 961 Reply Likes
I updated the title and main post to make it more obvious to Adobe that there's an easily reproducible bug.
Photo of Michael Newman

Michael Newman

  • 5 Posts
  • 1 Reply Like
My issue is slightly different to Louis's although I can reproduce his as well. Both his disappearing column issue and my losing selection issue relate only to a column filtering on GPS Data values.

Here's how to reproduce mine:
1, Select any source in Lightroom that has some images with GPS data and some without
2. In Grid in the area named Library Filter click on Metadata
3. Set any one of the 4 columns to filter on GPS Data
4. In the GPS Data column select "No Coordinates"
5. Switch to the Map module (menu Window, Map)
6. Switch back to Library Grid view (press G)

The column filtering on GPS Data has changed its selection to "All (2 GPS States)".
This happens every time,
Actually the selection is lost even when there is only one value, with or without GPS Data.

Maybe this should be posted as a separate issue, but (a) it may well be related and (b) I'm not sure how best to do that!

Regards, Mike
Photo of John R. Ellis

John R. Ellis, Champion

  • 3676 Posts
  • 961 Reply Likes
May be a different problem.

Please reference the new conversation here: Lightroom: Switching from Map to Library loses the selection in the GPS Data colu...
Photo of John R. Ellis

John R. Ellis, Champion

  • 3676 Posts
  • 961 Reply Likes
I forked your post to a new problem report, since it may have a different cause.
Photo of Petri Sirkkala

Petri Sirkkala

  • 10 Posts
  • 0 Reply Likes
Here is a video capture of GPS column being reset when returning from Map module to Library:

https://adobe.ly/2uKqScG
Photo of G0apher

G0apher, Adobe Employee

  • 19 Posts
  • 14 Reply Likes
Thanks for writing and the video.

I can see this bug only when switching to Map module and back, and only when the "GPS Data" column is included in the filter. I have filed a bug for the Engineering team to investigate and fix.