Lightroom 4: Crash when using the adjustment brush

  • 3
  • Problem
  • Updated 2 years ago
  • Solved
  • (Edited)
Using LR4 64bit- have been able to reproduce crash multiple times. Happens when using the adjustment brush. Click on the adjustment brush then click on one of the numbers for any of the adjustments- without clicking anything else (i.e. off highlighting the adjustment #) re-size brush using mouse wheel- crashes every time.
Photo of Jessica McMillan

Jessica McMillan

  • 2 Posts
  • 0 Reply Likes

Posted 7 years ago

  • 3
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15232 Posts
  • 2189 Reply Likes
Are you on Mac or Windows? What version of the OS?
Photo of Dorin Nicolaescu-Musteață

Dorin Nicolaescu-Musteață, Champion

  • 703 Posts
  • 38 Reply Likes
Crashed on the first attempt. Then once again. I used the Exposure slider.

Same in beta, but not in 3.6.

Win7 x64.
Photo of Jessica McMillan

Jessica McMillan

  • 2 Posts
  • 0 Reply Likes
I am on windows 7 x64 - all current updates.
Photo of Rikk Flohr

Rikk Flohr, Champion

  • 1373 Posts
  • 337 Reply Likes
I can duplicate. If I wait for a few seconds before resizing the cursor, the crash is avoided. If I go too fast it isn't.

It appears about three seconds (on my system) is needed between the click on the number and resize to avoid a crash.

I have logged a bug.

Mac appears unaffected.
Photo of Jim Espy

Jim Espy

  • 5 Posts
  • 0 Reply Likes
Same here as fully described exactly by Jessica. It happened to me three times already that Win7, 64bit has to shut it down. It's no fun especially if you have start all over again. :(
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15232 Posts
  • 2189 Reply Likes
Official Response
This issue was fixed in Lightroom 4.3 and later.