Photoshop: Lasso Tool line disappears after a few seconds of holding the 'alt' key down (win 10)

  • 3
  • Problem
  • Updated 5 months ago
  • Solved
  • (Edited)
When using the lasso tool to make selections, it makes sense to choose 'Polygonal lasso tool' and then hold the 'alt' key to change into freeform lasso as needed. Relasing the 'alt' key goes back to polygonal mode.
On Windows 7 and using Photoshop CC 2018, this was fine. However, moving to a Windows 10 machine with PS CC 2018 (and even with PS CC 2019) the lasso line disappears after a few seconds of holding the 'alt' key down. This makes detailed masking very tricky as you need to do it in very small parts.
I can only imagine this is some sort of OS related issue as on a W7 machine, it was all fine. It is only now we have moved our office over to W10 that we are getting this bug.
The machines are all high end: mine is an AMD Ryzen Threadripper 2990WX with 64GB RAM.
Photo of Richard Birket

Richard Birket

  • 7 Posts
  • 1 Reply Like

Posted 8 months ago

  • 3
Photo of Yuko

Yuko, Employee

  • 23 Posts
  • 12 Reply Likes
Hi Richard,
Have you tried updating graphic card driver? Also make sure to update Wacom tablet driver if you use one. Does it happen when you turn off "Use Graphics Processor" in Preferences > Performance? It requires reopening the document to become effective.
Photo of Richard Birket

Richard Birket

  • 7 Posts
  • 1 Reply Like
Hi. Thanks for the reply. These are brand new PCs, freshly installed. The cards are GTX 1080Ti. I disabled use gfx processer and restarted. Same problem.
Have you had a go yourself?

Another bug I have found is in the 3d filter to create a normal map: the various sliders etc don't update. You need to change from sphere to cube and back again to see updates. this is unworkable.

Do Adobe actually test these updates before shipping? We pay a lot of money for this.
Photo of Yuko

Yuko, Employee

  • 23 Posts
  • 12 Reply Likes
I have tried on my end but have not been able to reproduce so far.
Did you already try turning on "Legacy Compositing" in Preferences > Performance panel (requires reopening the document)? 
(Edited)
Photo of Richard Birket

Richard Birket

  • 7 Posts
  • 1 Reply Like
I'll try the legacy option. Here are a couple of videos to show the issues:-
Video1 - Lasso
Video2 - normal
Photo of Richard Birket

Richard Birket

  • 7 Posts
  • 1 Reply Like
Legacy mode seems to help the normal map creation. It has no effect on the lasso problem.
Photo of Yuko

Yuko, Employee

  • 23 Posts
  • 12 Reply Likes
Thank you for the videos! I still cannot reproduce the problem.

You mentioned it happens both with CC2018 and CC2019.

Have you already tried these?:

Reset Photoshop preference.https://helpx.adobe.com/photoshop/using/preferences.html

Does your keyboard have 2 Alt keys? Could you also try the other Alt key?




Photo of Richard Birket

Richard Birket

  • 7 Posts
  • 1 Reply Like
It certainly happened with both 2018 and 2019, but apparently only on a W10 machine. W7 seemed to be fine. We can't be absolutely sure of this though and tricky to test now that we have rolled out W10.
Photoshop has literally only been installed for about 4 or 5 days on these machines as they are brand new. However, I was experiencing it on my previous W10 machine (a dual Xeon 64GB machine) that I have upgraded from. Weird that we have 3 artists here on three brand new machines running W10 (two of the machines are Threadripper CPU based with 1080Ti cards, and the other is a high end intel 10 core machine with a 1070Ti card. All have 64 GB memory).
KB does have two alt buttons, but I just tried using the other one and we have the same issue. Are you a member of Adobe staff Yuko?
Photo of Yuko

Yuko, Employee

  • 23 Posts
  • 12 Reply Likes
Hi Richard, 
I can reproduce the problem now. Since you said it's happening in Windows 10 only and not in Windows 7 on the same machine, I was suspecting Windows 10 keyboard settings. Turning on Control Settings > Keyboard > Use Filter Keys > "Ignore brief or repeated keystrokes and change keyboard repeat rates" solved the problem for me. Could you try? I reported the 3D issue to engineers. 
Photo of Richard Birket

Richard Birket

  • 7 Posts
  • 1 Reply Like

Is this what you mean? I set the repeat rate down to slow (as per graphic) and it seems to be better. Still not perfect, but it takes longer before the lasso line starts to disappear. 
Photo of Yuko

Yuko, Employee

  • 23 Posts
  • 12 Reply Likes
Go to Windows Menu > Settings > Ease of Access > Keyboard > Use Filter Keys. Then turn on "Ignore brief or repeated keystrokes and change keyboard repeat rates". Sorry, I omitted the "Ease of Access" in the previous reply! Hope below screenshot helps. 

(Edited)
Photo of Richard Birket

Richard Birket

  • 7 Posts
  • 1 Reply Like
Whilst this is a fix, it means that when writing an email (for example) you can't hold your finger on the delete key to delete characters etc. 
Photo of Yuko

Yuko, Employee

  • 23 Posts
  • 12 Reply Likes
Official Response
I agree it is not a good workaround. Engineering is currently looking into the issue. We appreciate all the details and movie you have provided to us which led us to reproduce the case.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15462 Posts
  • 2292 Reply Likes
Please update to 20.0.2 and let me know if this update fixes your issue. Thanks!
Photo of Pete Green

Pete Green, Customer Advocate

  • 751 Posts
  • 147 Reply Likes
Official Response
This should now be fixed in the Photoshop 20.0.3 release.
Feel free to update Photoshop and let us know if this is resolved for you.

To update Photoshop CC to 20.0.3, click "Update" in the Creative Cloud desktop app next to Photoshop CC.
More detailed instructions for updating

Thank you for the report Richard!
Regards,
Pete