Photoshop: Lasso Tool line disappears after a few seconds of holding the 'alt' key down (win 10)

  • 3
  • Problem
  • Updated 2 months ago
  • Solved
  • (Edited)
When using the lasso tool to make selections, it makes sense to choose 'Polygonal lasso tool' and then hold the 'alt' key to change into freeform lasso as needed. Relasing the 'alt' key goes back to polygonal mode.
On Windows 7 and using Photoshop CC 2018, this was fine. However, moving to a Windows 10 machine with PS CC 2018 (and even with PS CC 2019) the lasso line disappears after a few seconds of holding the 'alt' key down. This makes detailed masking very tricky as you need to do it in very small parts.
I can only imagine this is some sort of OS related issue as on a W7 machine, it was all fine. It is only now we have moved our office over to W10 that we are getting this bug.
The machines are all high end: mine is an AMD Ryzen Threadripper 2990WX with 64GB RAM.
Photo of Richard Birket

Richard Birket

  • 7 Posts
  • 1 Reply Like

Posted 6 months ago

  • 3
Photo of Yuko

Yuko, Employee

  • 23 Posts
  • 12 Reply Likes
Official Response
I agree it is not a good workaround. Engineering is currently looking into the issue. We appreciate all the details and movie you have provided to us which led us to reproduce the case.
Photo of Pete Green

Pete Green, Customer Advocate

  • 750 Posts
  • 147 Reply Likes
Official Response
This should now be fixed in the Photoshop 20.0.3 release.
Feel free to update Photoshop and let us know if this is resolved for you.

To update Photoshop CC to 20.0.3, click "Update" in the Creative Cloud desktop app next to Photoshop CC.
More detailed instructions for updating

Thank you for the report Richard!
Regards,
Pete