Lightroom Classic: Export Photo - Rename preview when Title or Caption contains numerical xxx.yyy format

  • 2
  • Problem
  • Updated 4 weeks ago
  • Solved
  • (Edited)
Hello as a keen birder, I have a multitude of pictures of birds which I classify by Bird family(as title), bird name(as caption) ,date of picture taken and eventually sequence.I used to use the EXPORT function and do a rename of the DNG picture into a new Jpeg file name.As Title I had the format like as example 23.100, which would mean bird#100 out of family #43.So my resulting new Jpeg file name would be 23.100-birdname,date-sequence.Jpeg.However with version 9.1 this does not work anymore. ! ( Not sure when the change occurred as I went recently from 6.4 standalone- which is OK , to classic 9.1)The title with such a numerical format is ignored when I edit the Rename Preset like {title}-{caption},{date}-{sequence}.When I leave out title in the previous string, the rename works ( obviously with just caption,date and sequence).If I leave it in the string, just the first numerical digits before the dot , in the example 23, are shown, without caption, date,sequence !If I change the title from 23.100 to 23100, then the whole rename is shown correctly .I had posted this in the community forum under "Format of Title changed with version 9.1 ? Bug ?Another participant posted an illustrated reply where he could reproduce the error . His embedded screen shots shows the problem nicelyTHE PREVIEW IS WRONG BUT THE EXPORTED FILE SHOWS THE CORRECTLY RENAMED FILE NOTE that the same error occurs when such a format is in the caption. I have thousands of pictures thus classified into 200+ bird family folders with pictures in sequence as described above and I would like to maintain this system which was simple and ran smoothly before.Both Lighroom and Windows sort by such a format of filename.Fortunately I can do the export correctly , but it is a nuisance if the Rename screen is not showing what LR is actually doing .I hope that the LR team can fix this bug which somehow crept in with the newer versionsThank you very much Marc JUNIO
Photo of Marc Junio

Marc Junio

  • 4 Posts
  • 0 Reply Likes

Posted 7 months ago

  • 2
Photo of Bruce Houstoun

Bruce Houstoun

  • 124 Posts
  • 44 Reply Likes
This export "filename example preview" bug seems to occur for any metadata field or custom name that includes a period character within, it is not just affecting the Title field.
Any data after the "." is truncated in the visual example of your rename.

Win10/LR9.1
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7641 Posts
  • 1741 Reply Likes
Version 9.3, an update to Lightroom Classic, went live on June 15, 2020 and contains a fix for this issue. Please install the update and respond back if it does not cure the issue for you. Thank you for your patience!
Photo of John R. Ellis

John R. Ellis, Champion

  • 5139 Posts
  • 1460 Reply Likes
I just tested this in LR 9.3 / Mac OS 10.15.5, it worked correctly.
Photo of John R. Ellis

John R. Ellis, Champion

  • 5139 Posts
  • 1460 Reply Likes