Bug when syncing between enabled and disabled tone curve adjustments (toggled on/off)

  • 1
  • Problem
  • Updated 3 months ago
  • (Edited)
Merged

This conversation has been merged. Please reference the main conversation: Lightroom: Tone Curve Enabled not copied by Sync, Auto Sync, Presets, Snapshots

Since the last 2 updates, images will not correctly sync, apply presets, and save/portray snapshots if the tone curve's visibility is being switched from on to off or from off to on.  This has never been a problem before, and doesn't seem to affect any other develop panels (split tone, detail, color, etc.).  In every other panel, ALL settings, including the toggle switch that affects the panel's visibility will sync.  It doesn't matter if the visibility is being switched from on to off, or off to on.

To be clear about what I'm referring to when saying tone curve's visibility:  I mean the little toggle switch in the top left of the tone curve panel.  When hovering over the switch, Lightroom tool tips pops up with "turn on/off tone curve adjustments." The history panel records changes to this switch as "Enable Tone Curve     Yes/No".

Tone Curve visibility has problems in 3 areas:

SYNCING:

Example 1 (in Develop Module):

Image 1: with tone curve adjustment =Point Curve: strong contrast (toggled ON)

Image 2: with tone curve adjustment= Point Curve: medium contrast (toggled OFF)

Select image 1 first, then image 2 and sync tone curve (applies settings from image 1 to image 2). 

Results: Image 2 will now have Point Curve: strong contrast, but will still be toggled OFF (hidden).

EXPECTED RESULTS:  Image 2 will have Image 1's point curve: strong contrast AND reflect image 1's tone curve visibility: On.

 

Example 2:

Reset the tone curves as listed in example 1 and sync settings from image 2 to image 1.

Results: Image 1will have Point Curve: medium contrast BUT WILL BE TURNED ON.

Expected Results: Image 1 will have image 2's point curve: medium AND reflect image 2's tone curve visibility: OFF.


Example 3:

Try syncing 2 images with settings from any other panel, and the adjustments will sync AND the visibility state of the adjustment panel (toggled on or off).

 

PRESETS:

Same problem with presets.  For the tone curve panel: adjustments are updated acording to the preset, but NOT the panel visibility.  Presets affecting any other panel will update adjustments  AND the visibility state (toggle on/off) according to how the preset was saved. 

 

SNAPSHOTS:

Snapshots are finicky again with regard to Tone Curve visibility.  If the snapshot is of the tone curve visibility toggled off, it will not save it that way initially.  However, UPDATING an existing snapshot with current settings will get the snapshot to display a toggled off tone curve and it will switch back and forth accurately afterwards.  Every other panel's visibility will stick upon creating a snapshot and doesn't need to be updated.


This hasn't always been a problem.  And I recently set a new custom camera profile as the new camera default, without realizing that there was a hidden tone curve in the settings. Now I have 700 images that were imported with a tone curve toggled off and I can't undo it with a preset or by syncing.  All I can think of is to manually toggle each switch back on.  UGGG.  If I had caught it earlier, I would have just reimported them, but I already started adjustments before I figured out that Lightroom wasn't working the way it did before the update, and I'm not sure what will take longer...

Photo of Laura Kent

Laura Kent

  • 82 Posts
  • 8 Reply Likes
  • annoyed.

Posted 3 months ago

  • 1

There are no replies.

This conversation is no longer open for comments or replies.