Lightroom Classic: Treat JPEG files next to raw files as separate photos has no effect

  • 2
  • Problem
  • Updated 7 months ago
  • Not a Problem
  • (Edited)
Bug: Lr Preferences/General Import Options "Treat JPEG files next to raw files as separate photos" has no effect. Also after restarting Lr, once raw and jpg imported when checked, a later uncheck of this option has no effect, even if no edit has been applied. Of course it should be possible to alter this also after import. I am pretty sure being not alone expecting this like so.

Photo of Roland

Roland

  • 40 Posts
  • 6 Reply Likes

Posted 7 months ago

  • 2
Photo of Marco Klompalberts

Marco Klompalberts

  • 109 Posts
  • 26 Reply Likes
The way I understand it, is that it only applies to import (that's why it's under import options in the preferences).
When checked, LR will import both the JPEG and the RAW file.
When unchecked, LR will only import the RAW file and consider the JPEG to be a duplicate (if you have the "don't import suspected duplicates" option checked in your import screen.

It doesn't work for culling, like rejecting photos, star rating, color coding, keywords, etc.
These will always be treated on the selected photo(s) and not on their JPEG/RAW equivalent.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7716 Posts
  • 1779 Reply Likes
Marco is correct. This preference is not retroactive and only applies to new imports. 
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 2973 Posts
  • 1271 Reply Likes
If you want this to work retroactive, then right-click on the folder with the already imported images in the Lightroom folder panel and choose 'Synchronize Folder'.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7716 Posts
  • 1779 Reply Likes
That is one I didn't know, Johan!
Photo of Roland

Roland

  • 40 Posts
  • 6 Reply Likes
Thanks for replies. If I understand correct, I'll never get it together because slot 1 has raw files slot 2 jpgs (no perfect backup but it's a backup).
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 2903 Posts
  • 1247 Reply Likes
It should still be possible to use ‘Synchronize Folder’ after you imported both cards separately. Alternatively, you could use another method to copy both cards to the same folder on your hard disk, and then import the content of that folder in Lightroom.
Photo of John R. Ellis

John R. Ellis, Champion

  • 5178 Posts
  • 1478 Reply Likes
The behavior of Treat JPEG Files Next To Raw Files As Separate Files with respect to Synchronize Folder appears to have changed in some recent version.  Extra steps are now needed to apply the option to existing photos in the catalog.

Unchecking the option:

1. Select all the photos in the folder and Metadata > Write Metadata To File.

2. Do Synchronize Folder. It will show nothing to import. Click Cancel.

3. With all the photos still selected, do Metadata > Read Metadata From File.

4. The JPEGs will now be paired with their corresponding raws, but they'll also still show up separately in the catalog. Select them and remove them from the catalog.

Checking the option:

1. Select all the photos in the folder and Metadata > Write Metadata To File.

2. Do Synchronize Folder. All of the JPEGs that are currently paired with raws should be displayed. Click Synchronize.

3. With all the photos still selected, do Metadata > Read Metadata From File.


In both recipes, re-reading the metadata is necessary to get LR to update it's notion of the pairing of the files (as displayed in the Sidecar Files of the Metadata panel and the filename displayed with the thumbnail in grid view).