Lightroom: Very noisy previews in Library Loupe in zoom levels other than 1:1, 1:2

  • 2
  • Problem
  • Updated 8 months ago
  • (Edited)
Operating System: Mac OS 10.13.2
Exact Lightroom Version (Help menu > System Info): 7.1 [ 1148620 ]

I would be very grateful for help with the problem as described in What is that! Develop module not transferring c... | Adobe Community

This seems to be the bug with no possibility for workaround
Photo of Tomasz Rys

Tomasz Rys

  • 2 Posts
  • 0 Reply Likes
  • confused

Posted 9 months ago

  • 2
Photo of Alan Harper

Alan Harper

  • 426 Posts
  • 84 Reply Likes
Is this a Lightroom Classic CC issue? It looks like it is not, and shouldn't be in this forum.
Photo of John R. Ellis

John R. Ellis, Champion

  • 3739 Posts
  • 978 Reply Likes
In his other thread, Tomasz said the issue is with LR Classic CC, and he reports Help > System Info returning "7.1.".
Photo of John R. Ellis

John R. Ellis, Champion

  • 3739 Posts
  • 978 Reply Likes
From Tomasz's other thread:

This is again about Lightroom Mobile and Lightroom Classic CC. DNG Pictures created by Lightroom mobile on iPhone X.

Processing is done after cloud import to Classic. And what I see:

This is Develop module view:


In View module it is like that:


And I have more fun! Generated JPG picture is something between View and Develop.

Any ideas what is wrong?

Tomek
Photo of John R. Ellis

John R. Ellis, Champion

  • 3739 Posts
  • 978 Reply Likes
Please answer all these questions:

1. What are the precise settings in the Detail panel of Develop?  (A screenshot of the panel would be best.)

2. What level of zoom have you applied in Library Loupe (Fit, Fill, 1:1, or something else)?

3. Does the problem still occur when you select 1:1 or 1:2 zoom in Library Loupe?



Another person has reported that LR 7 does not show noise-reduction settings in Library with high-ISO raws unless 1:1 or 1:2 zoom is selected: https://feedback.photoshop.com/photoshop_family/topics/lr-classic-noise-reduction-effect-not-display...
Photo of Josh Silver

Josh Silver

  • 19 Posts
  • 0 Reply Likes
Photo of John R. Ellis

John R. Ellis, Champion

  • 3739 Posts
  • 978 Reply Likes
Josh,

I think that topic is about different symptoms, very coarse pixelation in Loupe regardless of whether noise reduction has been been applied in Develop.  Whereas Tomek's screenshots shown above, and the screenshots shown in Todd Shaner's post, show a problem with noise reduction not being applied in Library, not a general problem with pixelation.
Photo of Josh Silver

Josh Silver

  • 19 Posts
  • 0 Reply Likes
Ok thanks, fair enough. It was a moderator that originally told us that it was an issue with noise reduction not being applied and merged our thread into the noise reduction discussion. 
Photo of John R. Ellis

John R. Ellis, Champion

  • 3739 Posts
  • 978 Reply Likes
Yeah, it's likely there are multiple issues going on here: noise reduction not being applied in Library, noise reduction not being applied in Develop, pixelation of previews in Library.
Photo of Josh Silver

Josh Silver

  • 19 Posts
  • 0 Reply Likes
Sounds good. Thanks for helping to sort it out. At least the noise reduction in develop got sorted. 
Photo of Todd Shaner

Todd Shaner, Champion

  • 1074 Posts
  • 347 Reply Likes
This reply was created from a merged topic originally titled Noise reduction not being applied in Library module.

I am seeing an issue with noise reduction not being applied in the Library module when using any of the pyramid Zoom View settings except 1:1 and 1:2 with LR Classic on Windows 7 and Nvidia Quadro 600 graphics card.

The issue is observed when 'Use Graphics Processor' is unchecked or checked in Preferences. To duplicate what I'm seeing select a high ISO raw image with noise. Apply Sharpening Amount 100, Luminance 25 and Color 25 Noise Reduction. Next select 1:3 Zoom View and switch between the Develop module and Library module. It could take up to 15 sec. for the Library image to appear without noise reduction, but it will every time on my system! I'm guessing this is a Direct X vs Open GL rendering issue.

Update: The same issue can be observed using a JPEG export file of the above raw image file. Since no settings are applied to the JPEG this is strictly a display path rendering issue. I confirmed that LR CC 2015.12 does NOT exhibit this issue.



Note: This conversation was created from a reply on: Lightroom Classic: Noise reduction effect not displayed in Develop mode.
Photo of Tomasz Rys

Tomasz Rys

  • 2 Posts
  • 0 Reply Likes
John R. Ellis Please answer all these questions:
1. What are the precise settings in the Detail panel of Develop?  (A screenshot of the panel would be best.)
2. What level of zoom have you applied in Library Loupe (Fit, Fill, 1:1, or something else)?
3. Does the problem still occur when you select 1:1 or 1:2 zoom in Library Loupe?
#1 
  

#2 - Develop and Library "Fit"

$3 - This seems to work. When I selected 1:1 in Library after few seconds I got the same screen as in 1:1 in Develop. When in Library I turn back to Fit I see the same as in Develop. It means that this is rather screen handling problem than the real bug - however, I am not sure about final results on generated JPEG as I am not able to receive 100% the same results as I see in LR .... but this depends on assumed resolution, JPEG quality, and other parameters.

Maybe the my "display"  issue is related to the fact as the file is pre-edited in LR Mobile then imported to Classic.  Maybe the Library module doesn't see from the first try changes from LR Mobile when Develop recognized them immediately.

Thanks to all of you

Tomek
Photo of John R. Ellis

John R. Ellis, Champion

  • 3739 Posts
  • 978 Reply Likes
Todd, does this problem occur for you if the exported JPEG didn't have any noise-reduction and sharpening applied before export?
Photo of Todd Shaner

Todd Shaner, Champion

  • 1074 Posts
  • 347 Reply Likes
Yes, it exhibits very similar differences between the Library and Develop views. I also tried this test on noise-free ISO 100 raw file and JPEG export file with no Sharpening or NR applied. With the ISO 100 image the difference observed is that the Library module rendering appears sharper than the Develop module rendering. Normally the Develop module rendering appears sharper at less than 1:1 Zoom View due to using nearest-neighbor interpolation and the Library module using Bicubic interpolation.  1:3 Zoom View was used for all my tests since it is the most obvious. I also noticed another anomaly in that the Library image occasionally appears cropped when switching back and forth between the Develop and Library modules. Sometimes the Library rendering looks normal, but moving the image around with the hand tool will make it "snap" into the bad rendering mode. Again, this is at 1:3 Zoom view. The JPEG looks normal in PS and other viewers at the same 33.3% and other view size so there's nothing wrong with the export file. This is strictly a display path rendering issue!
Photo of Todd Shaner

Todd Shaner, Champion

  • 1074 Posts
  • 347 Reply Likes
I just opened raw file in PS and applied Image Sizing with 'Nearest Neighbor' Resample at 33.33% (i.e. 1:3). The image looks identical to the "bad rendering at 1:3 Zoom in LR. So it appears that something in the Library Preview generation or display rendering engine has changed in LR Classic.

I tried discarding and rebuilding 1:1 Previews with no change in the bad rendering. This should build new 1:1 previews and pyramid previews for 1:16, 1:8, 1:4, 1:3, and 1:2 using Bicubic interpolation. Apparently in LR Classic only the 1:1 and 1:2 pyramid previews are built using Bicubic and the rest using nearest-neighbor interpolation.

Photo of John R. Ellis

John R. Ellis, Champion

  • 3739 Posts
  • 978 Reply Likes
I updated the title to reflect the current understanding.
Photo of Todd Shaner

Todd Shaner, Champion

  • 1074 Posts
  • 347 Reply Likes
FWIW- I just tested the above DNG file with my settings in LR 5.7.1 and it does NOT exhibit any of these issues. So something was changed in LR 6 or 7 that is causing it. Just an FYI.