Lightroom Desktop: Problem with freezing when using the Healing Brush

  • 1
  • Problem
  • Updated 1 month ago
  • (Edited)
Hallo

I have a bug in the programme Lightroom. Tool called Healing Brush is freezing approximatelly 5 times in 15 minutes. It stops working and I can not use it. Only thing that helps is tu turn off and then on the whole programme. But then afer few minutes of using it happen again. Im adding a video of the behaviour. 

Thank you for your help


Lightroom version: 3.2.1 MAS [ 20200323-0920-697d32b ] (Mar 24 2020)
NGL Version: 1.14.0.16
Operating system: macOS
OS Version: 10.15 [5]
Photo of Vladimír Supik

Vladimír Supik

  • 6 Posts
  • 0 Reply Likes

Posted 1 month ago

  • 1
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7545 Posts
  • 1729 Reply Likes
A couple of questions to help us diagnose your issue.

Approximately how many healing spots do you have per image?
If you check Performance in Preferences do you have GPU Enabled?
Photo of Vladimír Supik

Vladimír Supik

  • 6 Posts
  • 0 Reply Likes
In one picture I use Healing Brush 3-10x (it depends on the complexity)

I have GPU on Auto


Photo of Vladimír Supik

Vladimír Supik

  • 6 Posts
  • 0 Reply Likes
I've tested switching it to Custom but it does anyway.


Photo of Vladimír Supik

Vladimír Supik

  • 6 Posts
  • 0 Reply Likes
I've tested switching it to Off but it does anyway. + makes a lags


Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7545 Posts
  • 1729 Reply Likes
Can you verify your system specs for me? 

Ram?
Free Disk Space?
Are you using any NAS or External Hard Drives?
Screen Resolution?
(Edited)
Photo of Vladimír Supik

Vladimír Supik

  • 6 Posts
  • 0 Reply Likes
System info from Lightroom:
Lightroom version: 3.2.1 MAS [ 20200323-0920-697d32b ] (Mar 24 2020)
NGL Version: 1.14.0.16
Operating system: macOS
OS Version: 10.15 [5]
Application architecture: x64
Computer model: iMac15,1 / Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz
Logical processor count: 8
Processor speed: 4,0 GHz
Built-in memory: 24 576,0 MB
Real memory available to Lightroom: 24 576,0 MB
Real memory used by Lightroom: 1 715,8 MB (6,9%)
Virtual memory used by Lightroom: 4 190,4 MB
Memory cache size: 471,5 MB
Internal Camera Raw version: 12.2.1 [ 415 ]
Maximum thread count used by Camera Raw: 5
Camera Raw SIMD optimization: SSE2,AVX,AVX2
Camera Raw virtual memory: 410MB / 12287MB (3%)
Camera Raw real memory: 411MB / 24576MB (1%)
Displays: 1) 5120x2880

Graphics Processor Info: Metal: AMD Radeon R9 M290X - 2 GB
Graphics Processor Detail: loaded: Yes, supported: Yes, compute: Yes, init: I4_GPU3, hard: success, soft: success, wl: Yes, bl: No
OS Media Capability: true

Application Folder: /Applications
Settings Folder: /Users/gioel/Library/Containers/com.adobe.mas.lightroomCC/Data/Library/Application Support/Adobe/Lightroom CC
Library Folder: /Users/gioel/Pictures/Lightroom Library.lrlibrary


HDD: (i don't use NAS or External hard drives)



Monitor:

Photo of Vladimír Supik

Vladimír Supik

  • 6 Posts
  • 0 Reply Likes
Info foto: (maybe it's related to the HEIC format)

 

Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7545 Posts
  • 1729 Reply Likes
Do you have evidence that HEIC performs differently than raw files do on your system? I wouldn't expect that to be the case. 

The problem I suspect up front is a 5K display with a fusion drive and only 2 gb of video memory. Those three things combined often present a performance bottleneck. You might want to try reducing your resolution by half so that your hardware can keep up.