Lightroom Classic: Luminance range masks do not work for grayscale images

  • 5
  • Problem
  • Updated 1 month ago
  • Solved
  • (Edited)
When Trying to restrict the effect of a gradient in a grayscal image with a luminance mask there is no visible difference in effected areas.

Running Mac Os X 10.13.4 on a 2014 Macbook Pro 15"
Photo of Benjamin Olry

Benjamin Olry

  • 2 Posts
  • 1 Reply Like

Posted 1 year ago

  • 5
Photo of Johan Elzenga

Johan Elzenga, Champion

  • 1981 Posts
  • 816 Reply Likes
I believe this has been reported before and is being looked at.
Photo of Benjamin Olry

Benjamin Olry

  • 2 Posts
  • 1 Reply Like
Thank you for your quick reply. I didn't find any mention of it with a quick search. I am sorry if I am being redundant about this. I can btw add to the issue, that it is not related to the file mode. Both RGB 16 bit tiffs containing only grayscale information as well as proper 16 bit grayscale tiffs show this behaviour. Cheers,

Ben
Photo of Sneed Hern

Sneed Hern

  • 1 Post
  • 0 Reply Likes
This reply was created from a merged topic originally titled Lightroom Classic: luminosity range mask does not work Leica Monochrom DNG files.....

I cannot seem to get the Lightroom  luminosity range mask to refine a selection working with Leica Monochrom DNG files.  The Select —> Color Range works in Photoshop.   I can make a selection in Lightroom using the brush/gradient tools but I cannot refine them with the Luminosity Sliders.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5496 Posts
  • 1157 Reply Likes
Official Response
Lightroom Classic CC 7.5 was released today and should address this issue.  If you don’t see the update in your Creative Cloud App, hit the [Ctrl/Cmd]+ [Alt/Opt]+[R] to force a refresh. 

Give the new version a try and let us know if it solves the issue. 
Photo of Carlos Oliveras

Carlos Oliveras

  • 130 Posts
  • 32 Reply Likes
Hi, I've noticed this issue with LR Classic 8.1 and Win 10 (1803). I had experienced this problem on a few occasions, but couldn't notice a pattern until now: it only happens with desaturated tiff images (maybe with psd's too). Then I found this report, but I see that, in theory, it was fixed with v7.5.

Anyway, I've captured this small video to show the issue, so that others can check too:

https://youtu.be/AmBHYC90Mcs

Is it me or is this same problem back? I've also tried disabling GPU, it didn't seem to make a difference.
Thanks.
(Edited)
Photo of Todd Shaner

Todd Shaner, Champion

  • 1383 Posts
  • 455 Reply Likes
I can confirm what you're seeing with LR Classic 8.1 on my Windows 10 1803 system when using RGB TIFF, PSD, or JPEG files that have been completely desaturated (i.e all pixels R=G=B) in PS.

Actual grayscale TIFFs, RGB TIFFs with only some desaturation, and Leica Monochrome B&W DNGs work correctly with the Luminance Range Mask controls.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5361 Posts
  • 1115 Reply Likes
Different than original reported issue.

Please reference the new conversation here: Lightroom Classic CC: Luminance Range Masking fails on PS Images where Desaturate...
Photo of Taylor Hain

Taylor Hain

  • 1 Post
  • 0 Reply Likes
I also have this issue. I'm running lightroom classic cc v8.2.1 on Windows 10. Luminance masks do not work with gray scale images (.tif format). Pretty frustrating.