Elements 14: Menu shows up in the wrong monitor/place on dual monitor system

  • 1
  • Problem
  • Updated 2 years ago
  • (Edited)
See attached screenshot - on a dual monitor system, if I use a floating image window, with the image on one monitor and the main PSE window on the other, then when I click the dropdown list in a PSE14 dialog, the dropdown selections appear way outside the PSE window, right over on the right-hand edge of the monitor. The PC is running Windows 10, has two same physical size monitors with different resolutions (two
80cm monitors, one is 2560x1600 and the other 3840x2160) and I'm using the
Windows 10 per-monitor display scaling (100% on the 2560x1600, 150% on the 3840x2160) to get same size window
elements on both monitors.
I have several other applications that I span across monitors in this way, with the image on one monitor and the main app window on the other - Thumbsplus, Silkypix, GIMP - and none of them display this problem.

The problem happens regardless of whether I have the image on the LH monitor and the main PSE window on the RH monitor or the other way around. The only difference is that if the main PSE window is on the LH (higher res) monitor, the dropdown lists appear out to the LH side of the PSE window, and if the main PSE window is on the RH lower-res monitor, they appear out to the right as in the screenshot. If I drag the floating image window back to the same monitor as the main window, the problem doesn't happen.
Photo of Nick Payne

Nick Payne

  • 8 Posts
  • 1 Reply Like

Posted 3 years ago

  • 1
Photo of Nick Payne

Nick Payne

  • 8 Posts
  • 1 Reply Like
I see that bowdlerisation is alive and well here. I submit a report with the word "bug" in the heading (and it's clearly a bug), but it then appears on the forum with a mysteriously changed heading. Capitalism melded with Stalinist leanings.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14485 Posts
  • 1874 Reply Likes
I edited the title to describe specifically what the problem is since the original title "Bug Windows UI Code" could mean anything. Since this is a bug reporting forum, the word "bug" was redundant. In any case, I've asked the Elements team to investigate.
(Edited)
Photo of Nick Payne

Nick Payne

  • 8 Posts
  • 1 Reply Like
Well then the edited title is incorrect. A GUI menu is not the same as a drop-down list (which is the item that displays the bug). The PSE menus do not have this bug, only the drop-down lists.

https://msdn.microsoft.com/en-us/library/windows/desktop/dn742404%28v=vs.85%29.aspx
Photo of Sandeep Singh

Sandeep Singh, Official Rep

  • 107 Posts
  • 18 Reply Likes
Hi Nick,

Could you please check one thing in PSE 14 preferences?
1. Press CTRL + K
2. Check for High Density Displays in the Display & Cursors
3. Make sure it is Automatic, try to change it to 100% also.


One more thing, could you please also check the windows' Display scaling level.
This article will help you: http://www.alphr.com/microsoft/microsoft-windows-10/1001272/how-to-set-display-scaling-in-windows-10
Let us know if this works out or not.

Regards,
Sandeep
Photo of Nick Payne

Nick Payne

  • 8 Posts
  • 1 Reply Like
Makes no difference whether the PSE scale factor is set to Automatic or 100%, the problem appears with either setting as soon as I drag a floating image window to a diffferent monitor to the main PSE window.

Lightroom 6, which I also have installed on the same machine, does not exhibit the same problem with the image on one monitor and main Lightroom window on the other.

As I mentioned in my original message, the Windows display scaling is set to 100% on the lower res monitor and 150% on the higher res monitor. If I set both moniitors to 100% then the problem does not appear, but that makes all the window elements (menus, dialogs, text, etc) impossibly small on the high-res monitor.
(Edited)
Photo of Surendra

Surendra, Employee

  • 168 Posts
  • 18 Reply Likes
Hi Nick,
Are you facing this issue only in PSE Editor or in Organizer too? If latter, please send the snapshot from Organizer too.

~Surendra
Photo of Nick Payne

Nick Payne

  • 8 Posts
  • 1 Reply Like
I don't use Organizer, only PSE, but I fired Organizer up to test. I see exactly the same problem with the dropdown lists in the Preferences dialog if I drag the dialog to a different monitor to the main Organizer window. Screenshot attached.

(Edited)