Photoshop CC 2015 : Duplicating/Pasting Causing Content Outside of Artboards to Disappear

  • 1
  • Problem
  • Updated 3 years ago
  • (Edited)
Task: Create instructional notes outside of artboards.

Problem: Duplicating any layer, folder, or pasting in anything from clipboard will cause folders outside of artboards to automatically jump and moved into an artboard. This also causes the content to completely disappear because it is now embeded in a artboard.

This issue stops us from being able to put notes outside of artboards.

Solution: This is really not a solution, but the only way to stop this is by turning off visibility on the folder. That is the only way.

Ideally whatever we do with other artboards and/or pasting items in should not affect folders outside of artboards. Anything we do within the artboard or outside of it should only affect that.

Thoughts?



As you can see, I have a IMPORTANT folder on top outside of artboards, to be used as notes. When I paste something in or duplicate a layer, Photoshop decides to move the IMPORTANT folder into an artboard. I can't even simply drag the folder back on top outside of the artboard because anything else I paste in will recreate this action.

I do not want this to happen...I really don't see why my actions outside of a folder + artboard should affect this.

Thoughts?
Photo of Jeff Huang

Jeff Huang

  • 4 Posts
  • 0 Reply Likes
  • frustrated

Posted 3 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 767 Reply Likes
Did you install the 2015.0.1 update?
Photo of Jeff Huang

Jeff Huang

  • 4 Posts
  • 0 Reply Likes
Hey Chris - I did. I'm on 2015.0.1
Photo of Jeff Huang

Jeff Huang

  • 4 Posts
  • 0 Reply Likes
I could also make a video showcasing this bug if you'd like.
Photo of Jeff Huang

Jeff Huang

  • 4 Posts
  • 0 Reply Likes
Chris - Is there anything else I could provide that can help with solving this issue?

Thanks!
Photo of Philippe Côté

Philippe Côté

  • 7 Posts
  • 1 Reply Like
I just solved the problem. First click on the Artboard tool (topmost in the tool palette). Then click on the Gear icon located in the Contextual Bar (top of the screen). Uncheck "Auto-nest Layers".

You shouldn't have anymore problems. ;)
Photo of O'Ryan McEntire

O'Ryan McEntire

  • 10 Posts
  • 0 Reply Likes
Except that turning this off makes it so you can no longer drag content into artboards from the canvas.

This is an awkward work around that is no better than turning off the layer visibility before pasting into the document.

I agree with the OP, content should not be moving around on it's own unless I am directly manipulating it to do so.