Photoshop: Brush size bigger than painted area

  • 1
  • Problem
  • Updated 5 months ago
  • Solved
  • (Edited)
Usually when using a hard brush, the circle which represents the bush side, and where it will paint, is the same size as the painting area. But at some point in the past (i have no idea when), my photoshop brushes have become larger than the painging area.

I have tried every brush setting, precise, normal, and full size. Full size is just larger than normal, but normal is still larger than the area painted by a 100% opacity 100% hard brush.

Im using CS5 on my mac.
Tried painting with a 1px brush, the opposite happens. When painting on white, at 1px photoshop paints 3 or 4 px a grey colour, it takes a few clicks to get a white pixel (surrounded by a couple of grey ones), though this isn't an issue, and i think its something to do with smoothing.

If I set the brush to 0% hardness, the brush circle size decreases, and if i then click repeatedly, the maximum area the brush covers (at the 50% point) is where the circle shows (how it should work, i think).

This happens on every brush, both the default ones and any custom brushes you have. It happens at any dimension or angle.
Also reset brushes back to default.

Still not working.
Photo of drcarvalho

drcarvalho

  • 6 Posts
  • 5 Reply Likes

Posted 7 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 769 Reply Likes
OK, if you're using Full Size Brush Tip cursors - then it should match.
But it sounds like you set it to "Normal Brush Tip" which shows the outline at 50%.

What OS version are you using? 10.7.x does have several video card driver bugs that mess up brush cursors.
Photo of drcarvalho

drcarvalho

  • 6 Posts
  • 5 Reply Likes
Thanks for your note, I'm using 10.7.2 with the latest update (video card releated ) that was just release yesterday or 2 days ago ...
I guess it is a bug, however if you have any other tip please let me know...

Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 764 Reply Likes
Which machine and GPU are you using? (Intel HD3000 has the most bugs)

Hopefully Apple will fix the remaining video driver bugs soon.
Photo of drcarvalho

drcarvalho

  • 6 Posts
  • 5 Reply Likes
I am using a i7 MacBook Pro 15 inches,
NVIDIA GT 330M 512MB

any tip ?!?
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13977 Posts
  • 1671 Reply Likes
Here's the expected behavior of the brush cursors:



Can you post something similar to show what you're seeing in terms of the relative size of the cursor to the paint that's being laid down?
Photo of drcarvalho

drcarvalho

  • 6 Posts
  • 5 Reply Likes
Jeffrey, thanks a lot for any help !!!
this pic below shows exactly my problem...
I am looking forward for your answering !!!

Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13749 Posts
  • 1601 Reply Likes
In your screen shot, the brush preview in the upper left (600), it looks like the brush hardness is less than 100% which would account for the area where the edge would be blurry if you click the mouse.
Photo of drcarvalho

drcarvalho

  • 6 Posts
  • 5 Reply Likes
Could someone help me please!!
Photo of PECourtejoie

PECourtejoie, Champion

  • 791 Posts
  • 282 Reply Likes
Did you reset the brush tool? (right-click on the tool preset picker on the option bar)
Is it the case also when transfer or pen pressure controls opacity is off?
Photo of drcarvalho

drcarvalho

  • 6 Posts
  • 5 Reply Likes
I solved it, the issues was related to Universal Access, the cursor size was a little increased... Finally I got it fixed !!!
Photo of Arabey McKenzie

Arabey McKenzie

  • 1 Post
  • 0 Reply Likes
dont just say got it how did you fix it!!?? im having the same problem i have no idea how it happened or how to fix it im freaking crying this is the worst!
Photo of Chad T.

Chad T.

  • 3 Posts
  • 1 Reply Like
If you have a mac, I think its under "accessibility". Then set your cursor options on the standard default settings. Thats how i fixed mine. I had played with the settings and made things too fancy for photoshop!
Photo of Margaret Sansone

Margaret Sansone

  • 1 Post
  • 0 Reply Likes
OK!  changing the cursor size and display contrast fixed the problem.  Does that mean that if I'm disabled and need to adjust those settings that I'll have the same problem again?  Not sure the trade-off is worth it.
Photo of Chad T.

Chad T.

  • 3 Posts
  • 1 Reply Like
I guess the only way is to switch back and forth when you use Photoshop. I have upgraded to El Capitan OS since it happened, so I don't know if it still does it - My Mac was running Yosemite OS at the time. I really liked the cursor adjustment until it messed with Photoshop.
Photo of Janek Szymanowski

Janek Szymanowski

  • 1 Post
  • 0 Reply Likes
WOW!!! Thanks guys this has bugged me for ages! What a pleasure to get it to work properly again :-D
Photo of Eric Nelson

Eric Nelson

  • 1 Post
  • 0 Reply Likes
I'm wondering if anyone has found a workaround for this as my cursor on 2 20" monitors gets lost, or my eyesight is failing me. :)

I'd like to use Universal Access to enlarge my cursor for general use but not affect CS5.

I've just recently caught up with the rest of the world upgrading from CS3 and a Power Mac G5 to an '08 Mac Pro running 10.6.8 with CS5 and this wasn't an issue on the G5 running 10.5.8.
Photo of Mattthew Brauer

Mattthew Brauer

  • 2 Posts
  • 1 Reply Like
Specifically, to fix this issue (Mac only), go to "System Preferences", find the "Accessibility" pane, and choose "Display" from the left column. Move the "Cursor Size" slider all the way to the left.

Note that this IS a Photoshop a bug because Photoshop cursors should not be effected by the system setting for mouse point cursor. For those of us with high resolution monitors, it's advantageous to have a larger mouse pointer for web browsing, etc., and we shouldn't need to turn that setting off whenever we use Creative Cloud.

This bug also applies to the eraser since it's a brush.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 764 Reply Likes
Photoshop cursors have to be affected by the OS scaling - because the OS is scaling them, not Photoshop.
Photo of Mattthew Brauer

Mattthew Brauer

  • 2 Posts
  • 1 Reply Like
That's correct. However, even though Mac OS is doing the scaling, Adobe can and should still respond to this issue that effects their product's users.

For example, it's possible for Photoshop software to read the system preference and compensate a 25% increase by scaling its cursor 25% smaller. At the very least, there could be a note in the Photoshop cursors preferences pane or in official documentation that this could happen.
Photo of Chad T.

Chad T.

  • 3 Posts
  • 1 Reply Like
Thank you so much for the fix, my Photoshop eraser cursor has been offset for a month just because I changed that cursor setting on a new laptop, I had spent hours trying to re-normalize it! I would have never thought of the 'Accessibility' factor.
Photo of Neko Carrillo

Neko Carrillo

  • 1 Post
  • 0 Reply Likes
Worked for us! Thank you so much!
Photo of Gary Cumiskey

Gary Cumiskey

  • 3 Posts
  • 1 Reply Like
Any fix for Windows? Not finding any so far.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 738 Reply Likes
See the previous posts for settings you may have changed to cause this.
Photo of Aaron Nichols

Aaron Nichols

  • 1 Post
  • 0 Reply Likes
For windows youll need to right click on the photoshop shortcut and go into properties. (Where you change compatibility settings for older Windows.) and you must change the dpi mode for higher resolution. Aaron Nichols
(Edited)
Photo of paulchrisjonesy

paulchrisjonesy

  • 1 Post
  • 1 Reply Like
This worked for me: I right clicked the Photoshop shortcut in C:\ProgramData\Microsoft\Windows\Start Menu\Programs, clicked Properties, clicked Compatibility, and then ticked Override high DPI scaling behavior. Then for 'Scaling performed by', I chose 'Application'. Click 'OK' and then reopen Photoshop.
Photo of Mackenzie Turner

Mackenzie Turner

  • 1 Post
  • 0 Reply Likes
This worked for me! 
Photo of IAH1

IAH1

  • 30 Posts
  • 8 Reply Likes
Try on windows CTRL + Right mouse button.
You will get a red preview and moving the mouse to the left makes it smaller, to the right bigger.
Up and down is opacity.
BTW: It would be better if up & down would be hardness, because opacity can you change with the number key pad much more precisely and for hardness it helps to have the red preview.
Photo of Allan Marquez

Allan Marquez

  • 1 Post
  • 0 Reply Likes
encountered this also, apple cursor setting solved it, just revert it to normal. :-)