Photoshop: Brush size and hardness shortcut not working anymore

  • 1
  • Problem
  • Updated 1 month ago
  • In Progress
  • (Edited)
For some reason I am not able to use the control/option brush shortcut anymore to control the brush size and hardness. I am running Photoshop CC 2017.1.1. I am using a Wacom as well and have tried using the old driver and the latest driver to see if either one would help with this issue and no luck. The keyboard is working fine as well, I have even tried two other keyboards and still nothing. Has anyone had this issue recently and found any solutions? It has really affected my workflow :(
Photo of Bianca


  • 1 Post
  • 0 Reply Likes
  • frustrated

Posted 3 years ago

  • 1
Photo of David

David, Official Rep

  • 3502 Posts
  • 588 Reply Likes
Howdy Bianca,

I heard of similar problems in other threads.  Those users reported that the updated driver solved their problems.  Nothing has changed on the Photoshop end of things, so if a new driver doesn't help, you might need to disable your tablet until a better driver is available.

Probably not what you want to hear, but hopefully helpful nonetheless,
Photo of johan alfredson

johan alfredson

  • 2 Posts
  • 0 Reply Likes
It dosent work for worked perfect on my mac but not in win 10
Photo of Chad Rolfs

Chad Rolfs, Employee

  • 106 Posts
  • 53 Reply Likes
Official Response
I was able to reproduce this issue and logged a bug.  I initially was going to suggest updating to Photoshop 2018 but it looks like there a different bug there where opacity is adjusted instead of hardness and there is no rubylith preview - logged and hoping that gets fixed in the next release.

Assuming you are talking about the shortcut: 
Ctrl+Alt+rightclick and hold (with pen or mouse), moving the mouse up/down/left/right to adjust size & hardness

Photo of Javier Sanchez

Javier Sanchez

  • 1 Post
  • 0 Reply Likes
If you have multiple languages (keyboards) set up, and you've switched from one to the other (e.g. ENGLISH to SPANISH) this will produce the same result.
Photo of David

David, Official Rep

  • 3413 Posts
  • 568 Reply Likes
Howdy Javier,

If you are using the Spanish app with a Spanish keyboard and Spanish shortcut file, everything is fine, right?  It should be...if not, that's a(n unreported) bug.

Photo of Mark Davidson

Mark Davidson

  • 11 Posts
  • 1 Reply Like
This just appeared on my iMacs yesterday. Mouse works fine but tablet will not work with HUD. Also cannot invoke contextual menu to choose brushes pane.
Photo of Suzanne Tourtillott

Suzanne Tourtillott

  • 3 Posts
  • 1 Reply Like
The ability to change brush size/hardness via keyboard shortcut Cmd+Opt+drag keeps popping in and out. Sometimes it works, other times not. Mostly not. (Or is it right-click+drag? I just learned about the shortcut so I still have to try both.)

Resetting all tools hasn't had any effect. BTW, I use a Magic Trackpad (large trackpad) rather than a mouse, so right-click+drag isn't a picnic.

Using Photoshop CC on Mac Mojave 10.14.5. 
Photo of Glenn Davy

Glenn Davy

  • 93 Posts
  • 22 Reply Likes
Try removing all functions on the pen buttons. I think it’s related to the R click option on the pen, but I’d start by removing all functions on the pen buttons and go from there.

Photo of Rory Chockman

Rory Chockman

  • 1 Post
  • 0 Reply Likes
This happened to me, I was painting and using this work flow of Option, Command to change the brush size and hardness. One day it stopped working and was cutting and duplicating instead. I later found out the Hot keys changed to Control, Option to change the brush size and Hardness. Dunno Why but thats how I'm working now