Bridge Libraries Panel

  • 1
  • Question
  • Updated 4 months ago
  • (Edited)
I just installed the latest version of Bridge. When I go to the Libraries Panel I get a notification in the middle of the panel telling me that I need install the Creative Cloud Application. It is installed and it is the latest version. From the Libraries Panel there is a link to get the Application. Clicking on that takes me to an Adobe download site. If I try to download from there it tells me the Creative Cloud App is installed and it opens it.

I also noticed that in the Photoshop Libraries Panel I see the same message and behavior.

Any ideas what's going on with this?
Photo of JC

JC

  • 75 Posts
  • 22 Reply Likes

Posted 4 months ago

  • 1
Photo of Avinash Kumar Singh

Avinash Kumar Singh, Employee

  • 27 Posts
  • 7 Reply Likes
Hi JC,

Sorry to know that you run under this issue. Please restart the system to resolve this issue. 
Please let us know if that fixes your issue.

Thanks,
Avinash
Photo of JC

JC

  • 66 Posts
  • 14 Reply Likes
I restarted the system, of course. It's a normal thing to do after making a new install. It did nothing to resolve the issue.

I finally called Adobe for assistance. After a few hours of troubleshooting the problem was not resolved and Photoshop was even more broken. After the tech gave up I plowed forward myself. I finally tried to uninstall Creative cloud and Photoshop. They did not uninstall completely so I ran the Creative Cloud Cleaner Tool, and the Adobe Creative Cloud Setup program again. After doing this the Creative Cloud app reported that LR Classic CC, Bridge 2018, and  Photoshop 2018 were not installed. I reinstalled them with fingers crossed, and miraculously they did and all is working again. What a pain.
Photo of James Lockman

James Lockman, Employee

  • 8 Posts
  • 4 Reply Likes
For me, it took signing out and signing back in to CC. Then the message went away.
Photo of JC

JC

  • 75 Posts
  • 22 Reply Likes
You had better luck than me. We tried that as you can imagine based on my earlier post. It is one of the first things tried.

We signed out of the Desktop CC app as well as Photoshop, Lightroom, and Bridge; we even rebooted after signing out completely. It made no difference in my case. By the way as mentioned, my case was elevated but have yet to hear one peep back from Adobe other than an email telling me that if they didn't hear from me in four days my case would be closed and considered solved. Great customer support!

I've been an Adobe booster for some time but after the recent Lightroom 4.3 update fiasco and now this I'm beginning to wonder a bit.
(Edited)