Bridge hangs while previewing AE animation presets

  • 4
  • Problem
  • Updated 3 years ago
Greetings,

I work in tech support at an arts college in Detroit, MI, and we are having an issue with Adobe AfterEffects and Bridge CC 2015.

Most of our labs consist of mac computers, mostly iMacs with at least 512MB VRAM (up to 2 GB VRAM) and at least 8 GB RAM (up to 16 GB). We are running the Yosemite (OS 10.10) on the macs as well.

There are a series of Animation Presets for text in AfterEffects (Lasso, Musical Chairs, Newton, etc.) that apply animated effects for text, obviously. Applying the effects works fine when working directly in AfterEffects, using the effects listed in "Effects and Presets" panel exclusively.

However, if we want to preview the effects first, i.e. clicking the little "dashes" icon to the right of "Effects & Presets" and selecting "Browse Presets", therein lies some issues. The process will open Bridge, and display the "Presets" folder.

Clicking on an effect in Bridge *should* load a preview of that effect in Bridge's "Preview" panel, which loops constantly (on my office iMac, it works fine).

On most of our lab computers, however, clicking on an effect does the following:

- Attempts to load the preview of any effect, but causes Bridge to hang indefinitely
- Sometimes the preview loading finishes, but displays a blank, black rectangle, while the playback loops constantly showing nothing

On *very* rare occasions in our labs, I've seen Bridge on a few computers preview the presets fine, but it was *very* inconsistent. The exception is my office iMac so far, on which Bridge previews animation presets fine and consistently. I don't see any significant difference between my iMac's specs and that of the the lab computers (my office imac has 8 GB RAM and 1 GB VRAM).

I've looked up this issue online, and it appears this issue, at least according to the Adobe forum threads, has been a recurring problem for various users across several versions of the Adobe suite, from CS6 up to recent versions of CC.

Aside from the occasional AfterEffects update, the issue was purportedly solved by (1) purging the Bridge cache, (2) deleting the "Switchboard" folder from the user's Adobe Preferences, or (3) completely clearing the Bridge preferences and re-launching Bridge. I've tried all of these things, and they do not work in making Bridge preview the presets properly.

If there's any help you could provide, I would be grateful. Is there a piece of software or file that Bridge needs access to in order to preview these presets?
Photo of J Conley

J Conley

  • 2 Posts
  • 1 Reply Like

Posted 3 years ago

  • 4
Photo of J Conley

J Conley

  • 2 Posts
  • 1 Reply Like
Forgot to mention this, as it is not crucial to the aforementioned issue, but for what it's worth:

I mentioned that selecting an Animation Preset from Bridge, previewing, and applying it in AfterEffects worked on my office iMac, *and* on rare, inconsistent occasions, it worked on some of the lab computers. However, on both my iMac and the lab computers, applying the effect this way shows this error in AfterEffects:

"ReferenceError: Function app.project.activeItem.selectedLayers[aLayer].applyPreset is undefined"

Despite this error, it still applies the effect successfully in AE, when applied from Bridge.
Photo of James McKey

James McKey

  • 1 Post
  • 0 Reply Likes
Just ran into this myself and really appreciated your thorough breakdown. I was getting the "ReferenceError" when trying to add a text "animate in" effect via the after effects "browse presets" (which as you said pulls up Adobe Bridge. I started with the Bridge cache purge to not effect but then when I deleted the Switchboard folder in Windows Explorer and rebooted I did get the process to work but like you I still get the ReferenceError, it's just annoying now but not preventing the feature from working. Do you know the best way to report a potential bug like this to Adobe?

Also, any luck on your own end? Figure out any correlation to when it happens? I have a Windows 7 x64 OS, multi-proc, and I installed Adobe Premiere Pro first, then after effects (and a few other apps like illustrator, photoshop, and prelude), then JUST installed Bridge this week to do the "browse presets" thing in After Effects. From the folder creation date/time stamp it looks like the Switchboard folder is created when Bridge is installed.