Bridge: Find fails until folder is listed

  • 1
  • Problem
  • Updated 7 months ago
  • (Edited)
Bridge search fails for a known file until the folder has been listed.

Steps:

1. Open a folder with a large number of images in Bridge browser.
2. While Bridge is slowly listing files and exporting thumbnails, type in a filename known to exist in that folder, in the upper right search box, press Return/Enter
3. Bridge will say not found
4. Search again once Bridge has listed down to that file
5. This time, the file will be found

This happens in folders where Bridge has an exported cache and which have been browsed dozens of times, as well as new folders.

Combined with the TERRIBLY SLOW folder listing (several minutes for folders that list in seconds with other image browsers such as Windows Photo Gallery and Faststone Image Viewer) this makes search unreliable and close to useless.

This also happens on the Mac. Verified on multiple computers with various versions of Windows and macOS, various versions of Bridge.
Photo of David Converse

David Converse

  • 448 Posts
  • 132 Reply Likes
  • like Bridge is a poorly designed piece of junk.

Posted 7 months ago

  • 1
Photo of Avinash Kumar Singh

Avinash Kumar Singh, Employee

  • 27 Posts
  • 7 Reply Likes
HiĀ David Converse,

For Bridge to search in the current folder.Bridge have to first generate the thumbnails , then only it can search the file .

Thanks,
Avinash
Photo of David Converse

David Converse

  • 448 Posts
  • 132 Reply Likes
I'm sure you understand that this makes search almost useless. Both Mac and Windows have system-level search APIs, you could use them?