Bridge 2020 on Mac - Full Screen Preview color wrong

  • 5
  • Problem
  • Updated 5 days ago
  • (Edited)
Why does it seem that every time a significant upgrade occurs to Bridge, the color of previews is broken? From memory, the profile attached to full screen previews is sRGB, or is it the monitor profile? Anyway, the color was always reasonably accurate compared to the open file in Photoshop, but from the 2020 update it seems to be way off. I'm sure the issue is complicated by the fact that I run multiple monitors. In the past I found a solution to my color woes by making sure Bridge/Photoshop is open on the primary monitor. But all seems broken today after the 2020 update. I hope the attached screen shot shows it - Photoshop on the left, full screen Bridge preview on the right. Can someone please offer a solution?


Photo of Benjamin Dearnley

Benjamin Dearnley

  • 7 Posts
  • 0 Reply Likes

Posted 1 month ago

  • 5
Photo of Roen

Roen

  • 12 Posts
  • 3 Reply Likes
Same problem with all my jpg previews.
(Mac High Sierra)
Photo of Martyn Poynor

Martyn Poynor

  • 1 Post
  • 1 Reply Like
Exactly same problem as Benjamin. I checked that all preferences in 2020 version were identical with 2019 version, but preview colour still very poor/ inaccurate. Always like to use latest versions but have already resorted back to 2019 version where preview colours are accurate. Also would like solution.
Photo of Marco Palermo

Marco Palermo

  • 2 Posts
  • 1 Reply Like
Same problem also for me, preview images are toned down...
Photo of Oleksandr Trokhymchuk

Oleksandr Trokhymchuk

  • 5 Posts
  • 4 Reply Likes
I have the same problem!!! And I need it to be fixed in order to keep using Bridge. It's impossible to use it.
Photo of Karen Holubek

Karen Holubek

  • 1 Post
  • 0 Reply Likes
Same problem!
Photo of Bernard Wolf

Bernard Wolf

  • 7 Posts
  • 0 Reply Likes
I had the same problem until I read that you should check the box next to software rendering in
Bridge preferences. That worked for me but caused a bigger problem....Bridge is now unusable because it is so slow. Went back to previous Bridge.
Photo of Ken B

Ken B

  • 10 Posts
  • 6 Reply Likes
Photo of kate

kate

  • 1 Post
  • 0 Reply Likes
same problem.
Photo of Bernard Wolf

Bernard Wolf

  • 7 Posts
  • 0 Reply Likes
Bottom line is Adobe needs to address this as soon as possible with an update.
Photo of Kristina Toddy

Kristina Toddy

  • 3 Posts
  • 0 Reply Likes
I had this issue a year ago... and reverted back to old version, and Now that Bridge 8 has become unusable - I REALLY need a fix for this!