Lightroom Classic: Blurry/Low Resolution Text Watermark on Activated Fonts

  • 3
  • Problem
  • Updated 8 months ago
  • (Edited)
All fonts that I activate through Adobe are showing as very blurry and low resolution when I try to use them as text watermarks. This occurs in the watermark preview window as well as once the photo is exported. No other fonts that come in Lightroom by default behave this way - only the fonts that I have (successfully) activated from Adobe. The newly activated fonts show just fine in their full resolution in Photoshop, so this is a Lightroom-specific issue.

I tried to show this to a support person in chat (Mayank) and he just clicked around blindly and made pretty much no real attempt to figure out the root cause of the issue. In fact, even after seeing and confirming the issue was present, once Mayank gave up and couldn't figure out the cause of the issue, he literally tried to tell me that it was the color I was using and that the font looked better in black! Extremely poor and honestly insulting support. This is a bug that needs to be resolved.
Photo of Ismael Lopez

Ismael Lopez

  • 3 Posts
  • 1 Reply Like
  • frustrated

Posted 10 months ago

  • 3
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 5664 Posts
  • 2261 Reply Likes
A screenshot and an example of a font name would help to reproduce this.
Photo of Ismael Lopez

Ismael Lopez

  • 3 Posts
  • 1 Reply Like
Sure, here is an example of the bad font. One other thing I forgot to mention is even how the color is not correct. Note this is not an issue with the Continuo font in particular. This happens with all of the fonts I have activated from Adobe.


Here is how all other fonts look that come by default with Lightroom. Note that it is crisp, not at all blurry, and the correct color.


Lastly, here is the font in Photoshop, showing that this is specifically a Lightroom issue since it works just fine in another Adobe Creative Cloud product


Not sure how clear these screenshots will look once uploaded, but I can tell you the first screenshot shows a low quality/blurry and miscolored font, while the other two look like full resolution vectors with no hint of quality degradation.
Photo of Sunil Bhaskaran

Sunil Bhaskaran, Official Rep

  • 486 Posts
  • 178 Reply Likes
Thanks for letting us know.
We will investigate?
Could you please let us know the operating system too.

Thanks,
Sunil
Photo of Ismael Lopez

Ismael Lopez

  • 3 Posts
  • 1 Reply Like
I was on a call with support yesterday and the rep on the phone said he was also able to replicate the issue, so this seems to be a bug. My workaround for right now is to create a .png watermark in Photoshop and then use that .png as the watermark in Lightroom. I really hope this can be resolved soon.

And I am on Win 10 v1903.
Photo of Gerard Bruneau

Gerard Bruneau

  • 1 Post
  • 0 Reply Likes
I was having the same issue with a true type font I downloaded. I took the true type font and put it through an online converter. https://onlinefontconverter.com. I selected a true type as the output and now its no longer distorted. I hope this helps!


(Edited)