Photoshop: Non-destructive blur for masking doesn't save correctly anymore

  • 21
  • Problem
  • Updated 4 years ago
  • Solved
  • (Edited)
In the recent day's it work for me, so I think only the last update could cause it.
If I use in a common mask the "blur"-function in the property panel PS show's it correct. But if I save it and look in LR for it the blur-effekt isnt present. Also if I save it as jpg from PS or LR the blur is vanished.
Photo of Armin Staudt

Armin Staudt

  • 73 Posts
  • 29 Reply Likes
  • really not happy

Posted 4 years ago

  • 21
Photo of Armin Staudt

Armin Staudt

  • 73 Posts
  • 29 Reply Likes
PS: if I export one of the recent tif's from LR it works, but if I open it in PS again and save it as jpg, I got the same bug. So old files work and new one's after the update not.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 855 Reply Likes
Which application are you having a problem with?
Which version?
Which OS version?
Photo of Armin Staudt

Armin Staudt

  • 73 Posts
  • 29 Reply Likes
PS = Photoshop 16.1.2
LR = Lightroom 2015.3
OSX 10.10.5
Photo of Kelvin Strepen

Kelvin Strepen

  • 5 Posts
  • 0 Reply Likes
Restart photoshop and try again later. Hope this will help you. 
You can see this video for your work. https://www.youtube.com/watch?v=QWmza2lqr1I 
Photo of Jaroslav Bereza

Jaroslav Bereza

  • 931 Posts
  • 245 Reply Likes
I also found a new bug few days ago. Is it same bug or should I create new topic?

Screencast here: https://youtu.be/X44JZoKRtFU
There is conflict between: Smart filters vs Smart filters blending mode

Photoshop forgets blending mode after reopening blur dialog.
Photo of eartho

eartho, Champion

  • 1329 Posts
  • 436 Reply Likes
Definitely create a new bug thread with this behavior.
Photo of Armin Staudt

Armin Staudt

  • 73 Posts
  • 29 Reply Likes
Here a screenshot:
Photo of Armin Staudt

Armin Staudt

  • 73 Posts
  • 29 Reply Likes
OK as a workaround I downgraded PS to vers. 16.1.1 via TimeMachine and the bug is gone.
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2677 Posts
  • 349 Reply Likes
A workaround is also to create a composite layer using Ctrl-Alt-Shift-E, save the JPG, then undo.
Photo of Armin Staudt

Armin Staudt

  • 73 Posts
  • 29 Reply Likes
Yes but the problem remains if you admin and export your work via LR
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2677 Posts
  • 349 Reply Likes
So then leave the composite layer if you're working in LR, afterwards.
Photo of Armin Staudt

Armin Staudt

  • 73 Posts
  • 29 Reply Likes
God idea
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2677 Posts
  • 349 Reply Likes
I reported this to Adobe from a different thread, yesterday:
https://forums.adobe.com/thread/2073689
Photo of eartho

eartho, Champion

  • 1329 Posts
  • 436 Reply Likes
Seriously??? Just tested this and yes, it's broken.

Did you all dissolve the pre-release team, or what?
Photo of Armin Staudt

Armin Staudt

  • 73 Posts
  • 29 Reply Likes
Yes. I ask in some FB-groups and Win-User have the same problem. First I thought only OSX-User were concerned.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 16649 Posts
  • 2717 Reply Likes
Thanks for entering the bug, Steve. We'll look into this.

The workaround in the meantime is go to Preferences > File Handling... and uncheck Save in Background.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 16649 Posts
  • 2717 Reply Likes
Can you guys test a workaround for me?

Go to Preferences > File Handling... and uncheck Save in Background. Does the files save with the blur correctly?
Photo of eartho

eartho, Champion

  • 1329 Posts
  • 436 Reply Likes
Yep, that workaround works for me.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 16649 Posts
  • 2717 Reply Likes
Thanks. Added the workaround to the official answer for others.
Photo of Jaroslav Bereza

Jaroslav Bereza

  • 931 Posts
  • 245 Reply Likes
What about my bug. Is it related? If this topic will be marked as solved and the new version will have my bug... I will create a new topic. :-)
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2677 Posts
  • 349 Reply Likes
Turn off Save in Background and try to replicate your bug. If it is fixed, then maybe it is related, otherwise create a new bug report, otherwise It'll be two versions later Adobe can fix it.
Photo of Yog Amreet

Yog Amreet

  • 5 Posts
  • 0 Reply Likes
Great! I have spent a lot of time trying to fix the same issue when the "Density" of the mask is not 100%, until I find that post. Unchecking "Save in Background" solved my problem. Thanks a lot!
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2677 Posts
  • 349 Reply Likes
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 855 Reply Likes
Ah, an important clue - thank you.
Photo of Tyler ONeill

Tyler ONeill

  • 4 Posts
  • 2 Reply Likes
I'm having this issue on Windows 10, and I don't seem to have the Save in Background option anywhere.

Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 855 Reply Likes
That might be because you are in Lightroom, and this topic is about Photoshop.
Photo of Tyler ONeill

Tyler ONeill

  • 4 Posts
  • 2 Reply Likes
You're absolutely right. It was tagged as Lightroom, and I noticed the issue in Lightroom. I have unchecked it in Photoshop and that fixed the issue. Thanks.
Photo of Terry King

Terry King

  • 2 Posts
  • 1 Reply Like
This reply was created from a merged topic originally titled Lightroom: Not displaying feather mask correctly.

Lightroom (CC 2015.4) does not preview the TIFF (or PSD) correctly when feathering is used on layer masks.

The shot at the top is in Photoshop (CC 2015.1.2) with a feather adjustment layer to create the eye shadow and below is how the TIFF looks in Lightroom. It also exports exactly the same and has caused a major issue when I've exported all my edits only to find the images I've sent to clients do not look as expected. My only option it seems at the moment is to create a merged copy layer before saving the image.

Photo of Michael Johnny Carson Kuby

Michael Johnny Carson Kuby

  • 3 Posts
  • 1 Reply Like
This reply was created from a merged topic originally titled Feathered adjustment layers from Photoshop CC are not feathered in Lightroom CC.

As described in the title, when I bring a Tiff photo into Photoshop, create an adjustment layer (curves for example), apply a mask, then feather, the saved image in Lightroom does not show those feathered edges. Instead, they all look like they were applied with a brush at hardness 0.

Top image shows lightroom version, bottom image shows photoshop version:

Photo of Stephen Newport

Stephen Newport

  • 286 Posts
  • 88 Reply Likes
Ditto here.  Not being able to save in background really slows my workflow down!
Photo of jochen strobel

jochen strobel

  • 11 Posts
  • 3 Reply Likes
Same problem for me PS and LR CC latest version, Jeffrey's workaround works too, thanks a lot!
Hopefully Adobe can fix it in the next update... when I export jpg it's always from LR.
Photo of Sam

Sam

  • 20 Posts
  • 5 Reply Likes
Registering that I also have come across this issue as of yesterday. I reported it in the Photoshop/Lightroom forum https://forums.adobe.com/message/8595698#8595698 
I have now unchecked save in the background, so hopefully the error will now stop occurring. Thanks for the work around details. 
I hope they fix it soon because I feel safer knowing that I have auto backups happening in the background.
Photo of Stephen Newport

Stephen Newport

  • 286 Posts
  • 88 Reply Likes
Two months..... any timeline as to when we can expect to be able to be able to background save again?
Photo of Stephen Newport

Stephen Newport

  • 286 Posts
  • 88 Reply Likes
For those who haven't figured out a better temporary solution yet, as a last step before saves you can create a merge visible layer at the top so you can still retain background saves while creating a bit more hassle and larger files. Hope this is fixed soon!
Photo of Patrick B

Patrick B

  • 3 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled Lightroom Rendering Bug.

Images edited in photoshop (whether through the "Edit In" Photoshop option or a file manually opened into Photoshop, saved, and then imported into Lightroom) that have an adjustment layer with a mask that has been blurred using the layer mask feather property, is rendered in Lightroom without the feather and instead shows the original edge of the unfeathered mask. The rendering issues is present when that image is exported out of Lightroom and printed.


Lightroom version: CC 2015.5 [ 1067055 ]License: Creative Cloud
Operating system: Mac OS 10
Version: 10.10 [5]
Application architecture: x64
Logical processor count: 4
Processor speed: 2.7 GHz
Built-in memory: 12,288.0 MB
Real memory available to Lightroom: 12,288.0 MB
Real memory used by Lightroom: 719.4 MB (5.8%)
Virtual memory used by Lightroom: 2,003.7 MB
Memory cache size: 791.1 MB
Maximum thread count used by Camera Raw: 4
Camera Raw SIMD optimization: SSE2,AVX
Displays: 1) 1680x1050, 2) 1920x1080

Graphics Processor Info: 
AMD Radeon HD 6770M OpenGL Engine

Check OpenGL support: Passed
Vendor: ATI Technologies Inc.
Version: 4.1 ATI-1.32.25
Renderer: AMD Radeon HD 6770M OpenGL Engine
LanguageVersion: 4.10
Photo of Patrick B

Patrick B

  • 3 Posts
  • 0 Reply Likes
Ahh see others posts on this issue so you can ignore my post.
Photo of Jens Scherer

Jens Scherer

  • 10 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled Layer Mask - Soft Edge not working in PS CC 2015.1.2.

After the latest update of Photoshop CC 2015.1.2 on OSX following bug appears
  • I am using a Layer Mask and change the settings "Soft Edge" or "Density" in the Properties panel of the Layer Mask.
  • In PS everythings looks fine, but if I place the file in InDesign the edge of the mask is hard and the density is 100%.
  • Saving the file as jpg or tif >>> same result
  • PNG and "Save for web" are working ...
Any ideas or common bug after updating?
Photo of Tone studio

Tone studio

  • 2 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled Why photoshop cc cliping mask with feather edge has sharp edges in indesign cc ?.

When you create clipping mask with feather edge in photoshop and place it to indesign clipping mask has sharp edges no feather effect.
Photo of Rick

Rick

  • 4 Posts
  • 1 Reply Like
Same issue here. Also, if it helps the diagnosis, I have feathered masks on separate layer adjustments and I can see both masks in Lr as a hard edge without feathering. I'm not sure if turning off background saves is the best solution if I risk losing work in progress. Turning off that preference also turns off Automatically Save Recovery Information Every: ... 

Thank you to the person that said the Adobe password also works here, I added my displeasure to the counter.

When I look for help from within the application it sends me to https://forums.adobe.com/community/photoshop. I wonder why the engineers hang out here rather than the help area they have programmed into the application.

Thank you to everyone for posting, I hope this will be fixed soon.
(Edited)
Photo of christoph pfaffenbichler

christoph pfaffenbichler, Champion

  • 1438 Posts
  • 251 Reply Likes
Have you turned off »Maximise Compatibility ...«? 

»I wonder why the engineers hang out here rather than the help area they have programmed into the application.«
If you are unclear about the nature of the forums.adobe.com Fora please read this
http://forums.adobe.com/docs/DOC-2325
Photo of Anne Rassbach

Anne Rassbach

  • 1 Post
  • 0 Reply Likes
This reply was created from a merged topic originally titled PHOTOSHOP CC 2015 - Feathered mask does not work when you save a jpg without merg....

When I save a jpg out of a psd and haven't merged my layers, all my feathered masks will be shown with hard edges in the saved jpg. (I am working with CC 2015.)