Photoshop CC 2019: Blending mode glitch

  • 2
  • Problem
  • Updated 3 months ago
  • Solved
  • (Edited)
I get this result when I apply a different blending mode to a layer and I think this is a bug. 

I open an image, add a fill layer, apply a 30% brush on the mask, change the blend mode. In Lighter Color and Luminosity, I get glitchy patterns to to one side of the image. 

You can see an example image here: https://drive.google.com/file/d/1dyhNnUmjV7KWPmewWQlhS7Y4-YXfWPSA/view?usp=sharing

You can view a video of what happens here: https://youtu.be/w2qkKsNaczA
Photo of Billy Newman

Billy Newman

  • 2 Posts
  • 2 Reply Likes
  • concerned

Posted 3 months ago

  • 2
Photo of Hannah Nicollet

Hannah Nicollet, Quality Engineer

  • 719 Posts
  • 312 Reply Likes
Hi Billy,

Thanks for letting us know. Would you please go to Preferences > Performance and check "Enable Legacy Compositing" and then try it again?

Regards,
Hannah
Photo of Andrew Sender

Andrew Sender, Employee

  • 50 Posts
  • 25 Reply Likes
Hi Billy,

This sounds like you're experiencing a bug we have addressed (https://console.getsatisfaction.com/photoshop_family/conversations/7811931).  Have you updated Photoshop to 20.0.1 or newer?
(Edited)
Photo of Hannah Nicollet

Hannah Nicollet, Quality Engineer

  • 719 Posts
  • 312 Reply Likes
Official Response
To check your Photoshop version and make sure you are up to date, please go to Help > System Info. In the top line you should see "20.0.1," which is the current version of Photoshop.

Thanks!
Hannah
Photo of Billy Newman

Billy Newman

  • 2 Posts
  • 2 Reply Likes
Hannah and Andrew,

The update fixed it. Thanks so much.