Photoshop 21.1.1: Blend modes doesn't work (Win10)

  • 1
  • Problem
  • Updated 4 weeks ago
  • Solved
  • (Edited)
Hi, I found a bug when blend modes don't work if a new layer is created in a double nested group and at the same time the top group has a clipping layer. It even doesn't work when the clipping layer is hidden. See attached PSD.
https://www.dropbox.com/s/fk36x5vsumn3nde/blending%20bug.psd?dl=0

Roman
Photo of Roman Divoký

Roman Divoký

  • 21 Posts
  • 7 Reply Likes

Posted 4 months ago

  • 1
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 17097 Posts
  • 2917 Reply Likes
I am not able to see a difference in how Photoshop rendered this file previously compared to the current version: Can you take a screen shot to show me the state of the layers panel and the canvas that shows the difference?
(Edited)
Photo of Roman Divoký

Roman Divoký

  • 21 Posts
  • 7 Reply Likes
Here is a short video https://www.dropbox.com/s/z69grahogtremc5/blending.mp4?dl=0
I also updated the PSD file on the link above (deleted 2nd layer in the nested group)
Photo of christoph pfaffenbichler

christoph pfaffenbichler, Champion

  • 1545 Posts
  • 311 Reply Likes
Does turning on Photoshop > Preferences > Performance > Legacy Compositing and restarting Photoshop have any bearing on the issue? 

Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 17097 Posts
  • 2917 Reply Likes
It does. If you enable legacy compositing it works.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 17097 Posts
  • 2917 Reply Likes
Thanks the video and new file have helped me understand/reproduce the issue. The workaround is to turn on Legacy Compositing. I've asked engineering to take a look. Thanks!
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 17097 Posts
  • 2917 Reply Likes
Official Response
This should be fixed in 21.2