Elements: Reinstall error says I need Internet Explorer 4.0 or greater to install it

  • 1
  • Problem
  • Updated 1 year ago
  • (Edited)
I am trying to install Photoshop Elements, which worked ok on my PC, onto my laptop.

When I do so it tells me that I need to have Internet Explorer 4.0 or greater to install it.

As I am using Internet Explorer 11.0 this should clearly not be happening.

How can I install Photoshop Elements on my (Windows 7) laptop?
Photo of Bill Mclintock

Bill Mclintock

  • 1 Post
  • 0 Reply Likes

Posted 1 year ago

  • 1
Photo of pkorisa

pkorisa

  • 3 Posts
  • 0 Reply Likes
Are you installung from a CD, or from a downloaded file? Installing PSE shouldn't have to do anything with IE. But, may be it's worth cleaning iut the "cache" of your IE, and also use Disc Clean to clear out Temp files. Reboot the laptop. And, then try to install PSE again. Let us know how it worked out.
(Edited)
Photo of Michel BRETECHER

Michel BRETECHER, Champion

  • 1315 Posts
  • 277 Reply Likes
This is what happens when you try to install a very old version of Elements in a new computer or drive/partition above 1 GB. The programmers at that time had no idea about such bigger drives. They could not provide a significant error message, so don't trust the error message. Even very old PSE versions may work if you are in a smaller partition and you open the program in compatibility mode. That said, trying to work with very old software on modern OS and hardware may be acrobatic...