LIGHTROM 5.6 Before & After feature often does not work properly when zoom in beyond 1:1

  • 1
  • Problem
  • Updated 4 years ago
  • (Edited)
Hi,

I don't know if it is a issue or it should work like this, but it seems a error for me, because sometimes when I'm checking the before and after for one photo and I want to zoom further 1:1, the image displayed on "before" part of the screen is the same as the "after".

I'm using LR 5.6 on a Windows 7 64bits machine, i7 2600K, SSD and 16GB of RAM.

Here is a example:

Using "Fit" zoom:


Using 3:1 zoom:
Photo of Rodrigo Tozzi

Rodrigo Tozzi

  • 27 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2657 Posts
  • 341 Reply Likes
The initial view in the Before will be the current (after) view, but eventually it should re-render as different. Does it never do this?
Photo of Rodrigo Tozzi

Rodrigo Tozzi

  • 27 Posts
  • 0 Reply Likes
The initial view in the Before is the image just after the import procedure, isn't it?

However, this is not the case here, I think that the image in the Before should be the same regardless the zoom applied, right?
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2657 Posts
  • 341 Reply Likes
The default Before image is as imported, plus any current crop/straighten settings so things generally line up.

However, using the toolbar buttons when Before/After is active, you can copy the current settings to Before, the Before settings to current and swap the Before and After settings so it's possible that the Before settings wouldn't be as imported but if you didn't do anything special they would.

In your situation it looks like the Fit view has different Before and After but the 1:1 view has the same After view for both. This will momentarily be the situation until the Before view is rendered at 1:1 but then the Before view at 1:1 should be the same as the Before Fit view other than the zoom level.

Since this is not happening, perhaps there is an error in the video driver or a corrupted preview cache or a corrupted catalog or a bug in LR.

My LR shows different Before and After views both for Fit and for 1:1 although the 1:1 Before view is delayed for a fraction of a second sometimes.
Photo of Rikk Flohr

Rikk Flohr, Champion

  • 1373 Posts
  • 336 Reply Likes
I find my Before and After are different regardless of zoom level - for Tiff and Raw.
Photo of Rodrigo Tozzi

Rodrigo Tozzi

  • 27 Posts
  • 0 Reply Likes
Zoom in a little further, for instance 3:1. For me, the before and after shows as expected when the zoom is set to fill, fit or 1:1, but, for almost all photos (I didnt understand why a few photos works as expected, maybe because the history contents...), the before and after looks the same when I zoom in to 2:1, 3:1...

I tried to rebuild the previews, but this didn't worked.