Lightroom Classic: Before-after comparison in Develop module

  • 1
  • Problem
  • Updated 2 weeks ago
  • (Edited)
For some time I have a problem with the before-aftercomparison in the development module of Lightroom. My suspicion of something“funny” going on dates back quite some time, way before LR Classic I think.
Lately, working on images with a lot of dark tones, I got worried.

I turns out that using the before-after comparisonbetween two identical development states, the comparison shows a visual differencein the dark tones.

This is very frustrating when finetuning the dark tones in an image.


Configuration: LR Classic 7.3.1., Windows 10.
Photo of Boudewijn Swanenburg

Boudewijn Swanenburg

  • 3 Posts
  • 0 Reply Likes

Posted 2 weeks ago

  • 1
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1399 Posts
  • 421 Reply Likes
Windows or Mac? Do you have a custom monitor color profile setup (meaning you calibrate, build and apply your own custom monitor color profile)?
Photo of Boudewijn Swanenburg

Boudewijn Swanenburg

  • 3 Posts
  • 0 Reply Likes
Configuration: LR Classic 7.3.1., Windows 10, display Eizo CX271 calibrated with i1Display Pro, set at 5500K, 80 cd and white-black ratio 250:1.
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1399 Posts
  • 421 Reply Likes
Would you able to reproduce and see the difference by setting the display color profile to some standard color space, such as sRGB?
Photo of Boudewijn Swanenburg

Boudewijn Swanenburg

  • 3 Posts
  • 0 Reply Likes
I rather do not like to fiddle with my display settings.
I do see however a similar behaviour on an not calibrated Windows laptop.See also this thread on Luminous Landscap forum, where the effect has been confirmed by Mark Segal using MAC.
http://forum.luminous-landscape.com/index.php?topic=125139.msg1047818#msg1047818