Lightroom Classic: batch rename continues to fail

  • 1
  • Problem
  • Updated 2 months ago
  • (Edited)
Merged

This conversation has been merged. Please reference the main conversation: Lightroom Classic: Batch rename errors

Hello 

Well, I have been working on an existing catalog that has been updated to LR Classic. as i work my way to being able to go to a single catalog.  

1.    I had several hundred photos, a mix of RAW and jpeg.  the photos are in two separate folders , taken on separate dates.  i wanted to rename each group separately.  I selected the first group in the film strip and used the metadata name tool, and successfully renamed all the photos in their folder, and in the catalog.  All the photos in the catalog were located properly with none missing.  

I selected the second group of photos and did the same procedure.   About 90% of the photos were renamed in the photo folder ( on my external drive). Some still have the DSC_xxx.RAW and .jpg names.   Inside the catalog,  all the RAW photos that were renamed show ok and none are indicated as missing.   ALL the jpeg photos have the old DSC_xxx.jpg. name and all show as missing.  That is because they don't exist in the photo folder.  so now I have jpeg photos in the catalog that dont physically exist anywhere. !!!

Some of the photos in the folder that appear to  have the old DSC_xxx name also appear to have a duplicate copy with the new name.    

THIS IS DEFINITELY A BUG IN LR.  Maybe it works fine in new pristine catalogs, as I tested, but this is the second time that I have an updated catalog that this has failed.  

I don't know if the folder with the unnamed photos are duplicates, or if i should save them and rename them to the end of the string.  IS there a good tool to find duplicate photos, that doesn't look at the names, as they don't match.  ??  

This was a catalog that was created in 2012 originally , I think, so it's been updated several times.

In the last few years , I always use BRidge to rename my photos before importing them into LR and have never had a problem.   i can't use Bridge to rename the photos that are already in catalogs, as they won't be able to find them and /or I'll loose all my editing.   



2.    Concerning merging catalogs,  I have one catalog that is a small subset of a larger catalog which contained selected photos that I was using to make some art posters.

if I merge the large one into the smaller one, will it recognize the 'new/other" photos that it doesn't have and import the photos,  edits, keywords, and recognize the ones already in the smaller catalog as duplicates, and keep all the key words and edits from the smaller catalog?

If I try to import the smaller catalog into the larger one,  it seem it might recognize everything as duplicates? is that true.  IF it doesn't import the photos, I guess it doesn't import the keyword, or anything else associated with the photo, even if it is different that what is in the smaller catalog.  

Is there some other way to do this.  



this is the april folder that was renamed successfully, and is ok in the catalog




this is the july folder that rename was not complete.  It started at _0001.   And the numbering is odd , like it only counts the RAW photos, but knows there are two associated photos.  ?  note at the bottom are some files with the old names.  i don't know if there is a new duplicate file with a new name.  Did the rename fail, or the cleanup fail?  The catalog only has the old DSC_XXX.jpg names so it cant find any of these files.  





I guess I can remove the jpg files from the catalog and import the new names, or just leave them out as I don't really need them, as I can make them from RAW files.  

This is the second time this has happened.  There is nothing wrong with my computer or hard drives.
if the virgin, new catalogs in LR Classic 7.4 work ok,  then there is a bug in the upgrade process that corrupts something.   


Is there some other way to rename the files.   I CAN'T relink them one by one, as there  might be hundreds or thousands ???

I may have 30 or 40 catalogs over the past 8 years, and 10's of thousands of photos. 
This bug has already messed up the raw photos  associated with two different catalogs. 
there is nothing wrong with my macbook pro  10.13.6 or my lightroom classic 7.4 

THIS IS A BAD BUG !!  

I can't really continue my migration to a single catalog until I sort this out , it's just creating more problems.   I'm trying to cleanup and standardize my existing catalogs , and delete unnecessary photos before merging into a single catalog.  

Thank You. !! 
Photo of wheel

wheel

  • 14 Posts
  • 1 Reply Like

Posted 2 months ago

  • 1
Photo of Petri Sirkkala

Petri Sirkkala

  • 10 Posts
  • 0 Reply Likes
To rename multiple photos in a catalog, select them in the library grid mode and click the small icon behind the right hand "metadata" section "filename" field. 

Select for example "Filename - Sequence" template, or edit one and save as a new naming template.

I hope this was what you needed for renaming.


(Edited)

This conversation is no longer open for comments or replies.