Photoshop: background flickers on Win8 ! (video driver)

  • 1
  • Problem
  • Updated 6 years ago
  • Solved
  • (Edited)
In PS CS6, when I work on my photos, say I change a level or a saturation value , or in fact every time I do something, the backround goes mental ! From gray to white back to gray and white again.....all that very quickly ! how can I fix that ?
Photo of Andy Selinger

Andy Selinger

  • 2 Posts
  • 0 Reply Likes

Posted 6 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 823 Reply Likes
I'm guessing you're on Windows.

It sounds like you're having problems with your video card driver (bugs).
You can go to the GPU maker's website and update the driver, or you can turn off GPU features in Photoshop's preferences (sometimes required if your GPU is so old that the driver is no longer updated).

If you're on Win8 - turn off GPU functions, or set it to "basic" mode for now. There are a lot of known display bugs in Win8, and more bugs in the drivers. We're working with Microsoft and the GPU vendors to get this fixed, and seeing if we can work around the worst of the issues in the meantime.
Photo of Andy Selinger

Andy Selinger

  • 2 Posts
  • 0 Reply Likes
Yes I'm on a brand new computer with W8... Thanks a lot for your quick reply, I'll do as you say and wait for more updates in the future, it seems that a lot of programs have some problems with W8.

Thanks Chris.
Andy
Photo of Roy Berger

Roy Berger

  • 4 Posts
  • 0 Reply Likes
I have the same problem and had to turn GPU features off. I am using an ATI 5790 video card.

Been waiting a while for the new driver, checking the vendors web site constantly. The vendor has not answered any queries detailing when a new driver addressing this problem might be released nor even acknowledging if one is in the works.

Is there any information available regarding progress between Adobe and ATI on rectifying this problem?
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 823 Reply Likes
You can set the GPU mode to Basic, and that should avoid the problem as well (while leaving GPU feature available).

No news I can share, but we are making progress.
Photo of Roy Berger

Roy Berger

  • 4 Posts
  • 0 Reply Likes
Thank you for the prompt reply Chris. Using GPU results in a variety of problems, some do not occur in "basic" mode but others remain. The only work-around I have found is to disable GPU in Photoshop CS6 preferences.

Being reassured that the problem is still being worked on is what I was wanting to find out. I will wait and hope that the resolution is not too far off. It is not a major problem just an inconvenience.

Regards,
Roy Berger