Lightroom Classic: B&W mix slider settings lost when converting to colour and back to B&W

  • 1
  • Problem
  • Updated 6 months ago
  • Acknowledged
  • (Edited)
When you are in B&W mode and have custom settings in the B&W Mix panel and then convert the image to colour and then back to black and white the B&W Mix panel sliders are all reset to zero.

This is changed from the previous version of Lightroom Classic where the settings were retained. 

This is an issue because if you switch back to colour (maybe to find the colour of what you are changing so you can grab the right slider) and back (to adjust that slider) all your previous settings are lost.

I'm assuming this is a bug that someone can fix for the next version.
Photo of Alan Bailward

Alan Bailward

  • 15 Posts
  • 0 Reply Likes
  • Frustration

Posted 6 months ago

  • 1
Photo of Sunil Bhaskaran

Sunil Bhaskaran, Official Rep

  • 330 Posts
  • 116 Reply Likes
Alan,
Thanks for reporting.
We are aware of this issue. A fix is under way.

Thanks,
Sunil
Photo of Just Shot Me

Just Shot Me

  • 213 Posts
  • 55 Reply Likes
In the meantime you should create a Virtual Copy of the image and convert that VC to B&W. Then all you have to do is go back to the original image to look at a color version it instead of switching back and forth.
Photo of john beardsworth

john beardsworth

  • 1082 Posts
  • 254 Reply Likes
Or use Undo.
Photo of Alan Bailward

Alan Bailward

  • 15 Posts
  • 0 Reply Likes
Yes, both valid answers - though as Sunil says it's an issue and it'll be fixed.  I will play with these ideas until a fix comes down. Thanks guys!