Awful performance

  • 1
  • Problem
  • Updated 3 months ago
  • Not a Problem
I recently upgraded my i7-6700k, to a Ryzen 7 2700x. Performance is AWFUL, literally rendering Lightroom useless. Any other software similar to lightroom? performance was already not too fantastic on the 6700k, but holy crap, the lagging, stuttering, slow load times, or just not loading anything. (takes a good 30 seconds to go into the cropping mode) I'm using full res (24MP) raw files, and using my gtx 1070 as an accelerator further deteriorates performance. Adobe is a complete joke for letting this pass. Wondering if Adobe plans to fix their app, that I pay monthly for, or are there any fixes? If this is considered acceptable I'm just transferring my work somewhere else.
Photo of Nick Beneke

Nick Beneke

  • 2 Posts
  • 2 Reply Likes
  • frustrated

Posted 3 months ago

  • 1
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 4286 Posts
  • 816 Reply Likes
Nick, 

The type of behavior your are describing is not typical. Let's see if we can get things figured out. 

Likely culprits for this type of performance:

#1 GPU
If you go to Preferences>Performance and uncheck the GPU box (or check it it was unchecked) does your performance change?  If so, then I would recommend a trip to nVidia's website (don't rely . on Windows update) and download the latest driver from nVidia for your GTX1070.  Some users report a better experience if you uninstall the old nVidia software prior to installing the new. 

#2 Bad install - if GPU doesn't seem to affect you and you are on the latest nVidia drivers, you may simply have a bad install. 

1. Restart your computer.
2. Use the Adobe Creative Cloud app to uninstall Lightroom Classic CC.
3. Restart your computer.
4. Install Lightroom Classic CC from the Adobe Creative Cloud app.
5. After installation, wait 10 minutes before using Lightroom. 

If those two steps don't provide improved performance then we probably need start looking at more detailed system information. 

Let us know how it goes!
Photo of Nick Beneke

Nick Beneke

  • 2 Posts
  • 2 Reply Likes
I tried it again a day later (no changes) almost all the issues are gone. gpu acceleration still slows it down; but thanks so much for the response.