Lightroom: How do I prevent Lightroom from automatically opening when I mount a camera card?

  • 1
  • Question
  • Updated 8 years ago
  • Answered
  • (Edited)
Merged

This conversation has been merged. Please reference the main conversation: Lightroom: How do I prevent Lightroom from launching when I plug in my card reader?

Lightroom 3 with Windows 7 (and ealier versions) everytime I add a memory stick lightroom opens. This would be OK if it were just pictures but a mempry stick full of word documents? its crazy and has to be fixed, please.
Photo of Juliet Evans

Juliet Evans

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 8 years ago

  • 1
Photo of Jim Wilde

Jim Wilde

  • 136 Posts
  • 26 Reply Likes
It's a user preference.

Edit>Preferences>General Tab. Uncheck the Import Option to "Show import dialog when a memory card is detected".
Photo of jdv

jdv, Champion

  • 728 Posts
  • 56 Reply Likes
You can also tell your OS what to do when a memory stick is mounted. Windows prefs somewhere.
Photo of Jim Wilde

Jim Wilde

  • 136 Posts
  • 26 Reply Likes
Of course you're right, as changing that preference in Lightroom IS telling the OS what to do (at least on Windows, can't say for Mac), as it causes the Autoplay settings for media types "Pictures" and "Mixed Content" to be changed from "Import using Lightroom" to "Ask me every time".

It also works in reverse....change either of those Autoplay settings manually and it will also change the Lightroom preference.
Photo of Rob Cole

Rob Cole

  • 4831 Posts
  • 388 Reply Likes
It is possible to add logic to detect whether memory card has photos/video to import vs other stuff and act accordingly.

On the other hand, its not that bad to just turn the auto-import option off and just open Lightroom whenever you want to.
Photo of Jim Wilde

Jim Wilde

  • 136 Posts
  • 26 Reply Likes
In theory, again on Windows, it's possible to set the Autoplay setting for Pictures media to be 'Import using Lightroom', and keep the setting for 'Mixed Content' so something else, e.g. "Take no Action" or "Ask.....".

Unfortunately it would seem that those separate settings only 'stick' until the next time you have cause to look at the Lightroom Preferences (for whatever unrelated reason) and you'll find that as soon as you OK out of them the 'Mixed Content' autoplay setting gets reset back to 'Import using Lightroom'. That feels like a minor bug.