Lightroom Classic: Attribute filter on color label says "No photos match the filter" on reopen catalogue

  • 1
  • Problem
  • Updated 7 months ago
  • (Edited)

When I close a catalogue with an attribute filter on color label applied, on reopening the catalogue, I get the message "No photos match the filter".

I have to close the attribute filter so all photos appear. By clicking "Attribute"

The when I activate the attribute filter again, the photos with the selected color label remain visible.

Until the catalogue is closed and reopened again.

 

Since the last upgrade to LR CC Classic.
Photo of Bart Dejonghe

Bart Dejonghe

  • 5 Posts
  • 0 Reply Likes

Posted 7 months ago

  • 1
Photo of Bhargav

Bhargav, Official Rep

  • 33 Posts
  • 7 Reply Likes
Hi Bart,

We need more information to verify the issue.
Which version of Lightroom are you using?

Can you provide the "System Info"?
Lightroom Classic -> Help -> System Info

Thanks,
Bhargav
Photo of Bart Dejonghe

Bart Dejonghe

  • 5 Posts
  • 0 Reply Likes
Sure, Bhargav:

Lightroom Classic version: 7.0.1 [ 1142117 ]
License: Creative Cloud
Operating system: Mac OS 10
Version: 10.12 [6]
Application architecture: x64
Logical processor count: 8
Processor speed: 3,7 GHz
Built-in memory: 32.768,0 MB
Real memory available to Lightroom: 32.768,0 MB
Real memory used by Lightroom: 1.736,2 MB (5,2%)
Virtual memory used by Lightroom: 3.484,3 MB
Memory cache size: 236,6MB
Maximum thread count used by Camera Raw: 5
Camera Raw SIMD optimization: SSE2,AVX
Camera Raw virtual memory: 953MB / 16383MB (5%)
Camera Raw real memory: 988MB / 32768MB (3%)
Displays: 1) 2560x1440

Graphics Processor Info: 
Metal: AMD Radeon HD - FirePro D500



Application folder: /Applications/Adobe Lightroom Classic CC
Library Path: /Users/Bart/Pictures/Lightroom/Unified_L7/Unified_L7.lrcat
Settings Folder: /Users/Bart/Library/Application Support/Adobe/Lightroom

Installed Plugins: 
1) AdobeStock
2) Aperture/iPhoto Importer Plug-in
3) Canon Tether Plugin
4) DxO PhotoLab
5) DxO PhotoLab Importer
6) Facebook
7) Flickr
8) HDR Efex Pro 2
9) Nikon Tether Plugin

Config.lua flags: None

AudioDeviceIOBlockSize: 512
AudioDeviceName: Built-in Output
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 44100
Build: Uninitialized
CoreImage: true
GL_ACCUM_ALPHA_BITS: 0
GL_ACCUM_BLUE_BITS: 0
GL_ACCUM_GREEN_BITS: 0
GL_ACCUM_RED_BITS: 0
GL_ALPHA_BITS: 8
GL_BLUE_BITS: 8
GL_DEPTH_BITS: 24
GL_GREEN_BITS: 8
GL_MAX_3D_TEXTURE_SIZE: 16384
GL_MAX_TEXTURE_SIZE: 16384
GL_MAX_TEXTURE_UNITS: 8
GL_MAX_VIEWPORT_DIMS: 16384,16384
GL_RED_BITS: 8
GL_RENDERER: AMD Radeon HD - FirePro D500 OpenGL Engine
GL_SHADING_LANGUAGE_VERSION: 1.20
GL_STENCIL_BITS: 8
GL_VENDOR: ATI Technologies Inc.
GL_VERSION: 2.1 ATI-1.51.8
OGLEnabled: true
GL_EXTENSIONS: GL_ARB_color_buffer_float GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_instanced_arrays GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_provoking_vertex GL_ARB_seamless_cube_map GL_ARB_shader_objects GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_sync GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_blend GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_bindable_uniform GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_depth_bounds_test GL_EXT_draw_buffers2 GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture_array GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_rectangle GL_EXT_texture_shared_exponent GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_timer_query GL_EXT_transform_feedback GL_EXT_vertex_array_bgra GL_APPLE_aux_depth_stencil GL_APPLE_client_storage GL_APPLE_element_array GL_APPLE_fence GL_APPLE_float_pixels GL_APPLE_flush_buffer_range GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_packed_pixels GL_APPLE_pixel_buffer GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_specular_vector GL_APPLE_texture_range GL_APPLE_transform_hint GL_APPLE_vertex_array_object GL_APPLE_vertex_array_range GL_APPLE_vertex_point_size GL_APPLE_vertex_program_evaluators GL_APPLE_ycbcr_422 GL_ATI_blend_equation_separate GL_ATI_blend_weighted_minmax GL_ATI_separate_stencil GL_ATI_texture_compression_3dc GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_ATI_texture_mirror_once GL_IBM_rasterpos_clip GL_NV_blend_square GL_NV_conditional_render GL_NV_depth_clamp GL_NV_fog_distance GL_NV_light_max_exponent GL_NV_texgen_reflection GL_NV_texture_barrier GL_SGI_color_matrix GL_SGIS_generate_mipmap GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod
Photo of Bart Dejonghe

Bart Dejonghe

  • 5 Posts
  • 0 Reply Likes
I didn't have any option checked under Metadata - Color Label Set.
Checking Lightroom Default does solve this issue.

Using Bridge Default seems to result in the same issue as well.

So, the issue at the root seems to be an error in converting the catalog to Lightroom Classic version 7.
(Edited)
Photo of Bhargav

Bhargav, Official Rep

  • 33 Posts
  • 7 Reply Likes
Hi Bart,

Issue is not reproducible at our end
Is the issue with Attribute filter (or) Metadata filter?

Whenever we close the Lightroom and repoen, No filters are applied by default.
Do you want to preserve the last used filter?

Can you provide us a video to help better?

Thanks,
Bhargav
Photo of Bart Dejonghe

Bart Dejonghe

  • 5 Posts
  • 0 Reply Likes
Hi Bhargav,


This is about the Attribute filter. 
If you want the filters to "stick" between closing and reopening, you have to close the padlock.




But as I wrote in my earlier reply, what is causing the issue I faced, was the fact that under Metadata - Color Label Set no Option was Checked.
I checked 'Lightroom Default' and now the issue does not present itself any longer.

The root cause of the problem is that during the upgrade of my LR6 CC Catalogue to LR7 CC Classic Catalogue none of the options under Metadata - Color Label Set got checked in the process.

Once I did this manually, the issue - for me - was gone.  This might not be the case for other customers that have yet to upgrade!



If you can obtain / create an installation with no Option checked, you will see the issue present itself.
That is, if you close the padlock so that filters get applied on reopening.

I heard that setting the Option to 'Bridge Default' will also cause the issue.

Best,
Bart
Photo of Bhargav

Bhargav, Official Rep

  • 33 Posts
  • 7 Reply Likes
Hi Bart,

Thanks for the investigation.
Good that you're able to resolve it.

Thanks,
Bhargav