Photoshop 21.1.1: Artifacts on grouped layers (Win10)

  • 2
  • Problem
  • Updated 4 months ago
  • (Edited)
Hi, artifacts (dark edges) are shown on grouped layers if a clipping layer is applied. It's visible even if the clipping layer is hidden.
See attached PSD
https://www.dropbox.com/s/idz774k9p191c0j/artifacts.psd?dl=0

Roman
Photo of Roman Divoký

Roman Divoký

  • 21 Posts
  • 7 Reply Likes

Posted 4 months ago

  • 2
Photo of SB

SB

  • 6 Posts
  • 1 Reply Like
Same here (Mac OS, problem first recognized with PS 21.0.3.) with layer groups containing layers with layer effects like drop shadow. Creating an adjustment layer over the group and clipping it with the group, cutting edges appear on the drop shadow.
(Edited)
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 17097 Posts
  • 2917 Reply Likes
Your issue should be remedied in 21.1.1 update.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 17097 Posts
  • 2917 Reply Likes
If 21.1.1 doesn't fix your issue, please post your PSD for us to troubleshoot. Thx.
Photo of SB

SB

  • 6 Posts
  • 1 Reply Like
Sorry, I had too many issues with 21.1.x therefore I returned to 21.0.3.
Actually, I found out to put the layer effects to the groups folder. With that, the shadows are good.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 17097 Posts
  • 2917 Reply Likes
Photo of Roman Divoký

Roman Divoký

  • 21 Posts
  • 7 Reply Likes
I wouldn't say so. Don't you see it in the PSD I posted? Try to clip/unclip the top adjustment layer.
Here are 2 images for comparison. https://www.dropbox.com/sh/hib3pcrh0o38ly8/AAAL2jfB5mh9WZkRu1revaHIa?dl=0

Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 17097 Posts
  • 2917 Reply Likes
Official Response
Got it. This one isn't affected by Legacy Compositing. I'll ask engineering to take a look.