Application of preset is sometimes not recorded in History

  • 1
  • Problem
  • Updated 10 months ago
  • Not a Problem
  • (Edited)
Create a preset called TEST that changes ONLY the Exposure.   This can be ANY adjustment but we will use exposure for this example.  

Select a photo

1. Apply preset. TEST. (Its added to History)

2. Add Contrast.  (Its added to History).  This adjustment CAN NOT be an Exposure adjustment or the Preset will record in History in step 3.  

3. Apply preset TEST  (Its not added to History) (It appears to the user it didn't work!)

4. Add Highlights.  (Its added to History)

5. Do an Undo.   (popup says "Undo Highlights")

6. Do an Undo.  (popup says "Undo preset TEST" although this step is not in History)

7. Do an Undo.  (popup says "Undo Contrast)

IMPORTANT NOTE:  Step two can not be an Exposure change using the above Preset example.  If the Preset was only for Clarity than step two could not be Clarity.  It appears that for some reason Lr is checking to see if the preset is making changes to the sliders before recording a history step.

It appears that the problem is that the second application of TEST is being correctly applied IF CHANGES ARE MADE IN HISTORY after the first application of TEST but the step is not recorded in History.   Previous versions of Lightroom before Lr7 would record this in History.  Not recording the step in history is what is disconcerting to the user and should be fixed.

I do agree that TEST should not be applied twice in a row but if an edit step is done after the first application of TEST is should apply AND BE RECORDED IN HISTORY a second time.  It used to previous to Lr7

I think this is related to a couple other preset bugs I have submitted.

This is on Lr 8.1 and macOS 10.13.6


Photo of Robert Somrak

Robert Somrak, Champion

  • 406 Posts
  • 138 Reply Likes

Posted 10 months ago

  • 1

Be the first to post a reply!