Photoshop: Applescript Changes in CS5?

  • 1
  • Question
  • Updated 5 years ago
  • Answered
  • (Edited)
Opening an image using applescript commands seems to be broken or drastically changed. I have tried several suggestions found on various forums but none work for me. Even the official Photoshop scripting guides don't seem to work.

I have been scripting for 10+ years. I am running 10.5.8 with Photoshop CS5 version 12.0.4 x64
Photo of Steve Stofiel

Steve Stofiel

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 8 years ago

  • 1
Photo of Brett N

Brett N, Official Rep

  • 2260 Posts
  • 123 Reply Likes
Can you provide a specific example? A sample script?
Photo of Steve Stofiel

Steve Stofiel

  • 2 Posts
  • 0 Reply Likes
This simple script gives the error below... I have tried many variations including using POSIX path's. Running Photoshop in 32bit mode works. The interesting thing is if I switch back to 64bit mode it still works but this is not consistently/reliably.



tell application "Adobe Photoshop CS5"
set filePath to "Bank:Layered_Files:123400-123499:123450.psd"
open file filePath
end tell


Adobe Photoshop CS5 got an error: General Photoshop error occurred. This functionality may not be available in this version of Photoshop.
-
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15633 Posts
  • 2368 Reply Likes
Official Response
Photo of David Luu

David Luu

  • 2 Posts
  • 0 Reply Likes
It seems the links referenced here are no longer valid? They return 404. Can we get updated links? Or post directly the solutions mentioned in those links?