Photoshop & Lightroom: Won't print 13 x 19 on Epson R3000...

  • 1
  • Problem
  • Updated 5 years ago
  • (Edited)
Neither Lightroom 3.6 or Photoshop CS 5.1 on Mac OS 10.5.8 (desktop iMac) will print size Super B (13 x 19) on Epson Stylus Photo R3000. Though it looks fine in Print Preview and there are no error messages, it prints the image smaller (8" instead of 13"), in the center of the page. The same image prints properly (full 13 x 19) via iPhoto. It prints fine from the same programs (LR & PS) on my laptop (MacBook), which is OSX 10.6.8. All of the software, drivers and print settings are the same (and up to date). Why does it print correctly from laptop but not desktop? Is it because the laptop is a slightly newer OS? How can I get it to print correctly from Lightroom & Photoshop on desktop?
Photo of Peaceful Woods

Peaceful Woods

  • 3 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
That is an issue with your Epson printer driver.
Applications get the page size information from the driver, and print where the driver lets them.

Why does the behavior differ between applications? Because the code called inside the driver differs (different printing APIs, different color management models, etc.).
Photo of Peaceful Woods

Peaceful Woods

  • 3 Posts
  • 0 Reply Likes
Thank you for your reply, Chris. Any idea which printer driver is best for Adobe apps. on this printer & OS 10.5.8? It came with 8.44, which is the one that works fine on my laptop and in others apps. on my desktop. On the Epson web site, the download for 10.5.8 was 8.36. I couldn't even try printing from that, as nothing would happen when I clicked on Print Settings. The few times I could open it, it was garbled (which I have a screen shot of) and the menus didn't work. After several tries (uninstall/install), I went back to 8.44 so I could at least do some printing.

Interestingly, a few days ago, I just received driver 9.0 on my laptop via an Apple software update. It doesn't update to that on my desktop... maybe because of the different system version. Wondering if I should try to find 9.0 online and try it.

Epson is still saying it's an Adobe thing, since it's only malfunctioning in LR & PS. Besides drivers, I've also tried every print setting/combination of settings possible. Any other ideas? Any help/advice would be greatly appreciated! I really like the printer (output color, etc.), but I bought it for printing to 13 x 19!!