Photoshop CS6: Analysis Measurement Gray Values Incorrect?

  • 1
  • Problem
  • Updated 5 years ago
I'm trying to use the Image Analysis functionality of PS CS6 to obtain brightness levels from an image.

To test the "Gray Value" measurment, I've created 11 patches from 0%-100% in 10% increments. I used the fill tool (Shift-F5) and specified values using H=0, S=0, B=.

The respective RGB components of the generated patches are exactly as expected (255*percentage_value).

The measurements obtained through "Record Measurement", however, do not agree, with the exception of the 0% and 100% extremes, which are reported with 0 and 255, respectively.

Inbetween, there is disagreement which rises from 0 @ 0% to the highest (5 @ 50%) to then decrease again to 0 @ 100%.

Here is the series by which the reported Gray Values are too low (from 0% - 100%): 0, 3, 3, 4 4, 5, 3, 3, 2, 1, 0.

How come?

I've tried removing colour profiles (to exclude gamma encoding issues) and using different colour spaces and/or models, with no change in behaviour.

All my patches are pure gray so there shouldn't be any problem with unexpected colour weighting.

One funny observation I've made is that even though the patches are a 100% homogenous, PS reports different miminum and maximum values. For instance for the 50% brightness patch (RGB triples of 128, 128, 128), the report is MinVal=123, MaxVal=124, MeanVal=123.934809.

Clearly, the value for all three aspects should be the same, and I expect the value to be 128.

What am I missing?

I'm using PS CS6, Version: 13.0.1 (13.0.1 20120808.r.519 2012/08/08:21:00:00) x32, on Win 7.
Photo of TK

TK

  • 531 Posts
  • 109 Reply Likes

Posted 5 years ago

  • 1
Photo of TK

TK

  • 531 Posts
  • 109 Reply Likes
In case anyone has the same problem. ImageJ does what I want. Quickly. Correctly.