Photoshop: Display artifacts and crashing

  • 1
  • Problem
  • Updated 4 years ago
  • Solved
  • (Edited)
Always I'm using the eyedropper tool Photoshop crashes. The same does happen after loading a channel as a selection and changing of the window of channels to the window of layers. I'm using the current version of Photoshop CC on a system of Windows 8. Since lately there are pink areas in parts of the picture (-> image). When I zoom in these areas are gone. These only are seeable with an activated RGB channel. Directly before the crash all channels have a transparent preview.
Photo of Justus Steinfeldt

Justus Steinfeldt

  • 1 Post
  • 0 Reply Likes
  • frustrated

Posted 4 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 812 Reply Likes
The artifacts pictured look like video driver artifacts. Update your video card driver from the GPU maker's website. If you cannot update the driver for some reason, try disabling GPU drawing in Photoshop's preferences, then restarting Photoshop.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14049 Posts
  • 1735 Reply Likes
Determine what video card you have and go directly to the manufacturers website (nVidia or ATI/AMD) and download the latest driver: http://blogs.adobe.com/crawlspace/201...

After you have the latest driver, Try restoring your preferences: http://blogs.adobe.com/crawlspace/201...

If doing both of those doesn't help, select Edit>Preferences>Performance... and click [Advanced Settings...]. Set the Drawing Mode to "Basic" and restart Photoshop.
Photo of Anton Averin

Anton Averin

  • 2 Posts
  • 0 Reply Likes
Just got this one myself.
Updating to latest NVidia driver didn't work, trying to update Photoshop itself.
Photo of Anton Averin

Anton Averin

  • 2 Posts
  • 0 Reply Likes
Resetting preferences seem to have did the trick. Hope it doesn't reoccur tomorrow