Lightroom Classic: All spot removal healing brush edits not exporting

  • 1
  • Problem
  • Updated 1 year ago
  • (Edited)
Sometimes when I export an image, all of the edits I've made export EXCEPT the spot removal healing brush edits. Not only that, some of the healing brush edits have now disappeared in Lightroom after the export. A recent example is that I had to take a dead pixel out of all of my images, that worked and those edits are still there, but some more complicated edits of a blemish on a girls face did not process out in almost all of those photos and those spot removal edits have now disappeared in Lightroom. Any idea what's going on here?
Photo of Peter Thompson

Peter Thompson

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 1 year ago

  • 1
Photo of Roland


  • 6 Posts
  • 0 Reply Likes
Ummm, will check the next time when I run into the same task and will keep you updated. - However, this is probably one of this issues, where we all should be able to utilise something like - But unfortunately, Adobe shuns customer contact like the devil the holy water (in German we say so, translated literally, I have no clue if translation of the saying exists ;)).
Photo of John R. Ellis

John R. Ellis, Champion

  • 5111 Posts
  • 1446 Reply Likes
This forum is the official place for customers to report bugs. Adobe product developers read everything posted here and engage on a large number of the reports, escalating them to the engineering team and marking their status here.

It's good that Peter reported this problem to get it recorded and allow others who experience these symptoms to add their Me Toos, helping determine if there's a pattern and narrow down the cause.  But short of a step-by-step recipe reproducing the problem and/or sample photos illustrating the issue, it will be hard for Adobe to take any action on this initial report.

Photo of Peter Thompson

Peter Thompson

  • 2 Posts
  • 0 Reply Likes
I wish I could provide more information, the only thing I can think of is that overdoing it on the spot removal "overloads" the system and it just decides there are too many large, irregular spots to remove and deletes them. As this problem is random and the original edit has been deleted, there isn't really anything to share. I will say the it tends to happen when I've removed something large where I have to paint over the area instead of just clicking an exact circle to remove whatever it is I'm trying to get rid of. Really just wondering if anyone else has experienced this issue or if I'm crazy.
Photo of Edmund Gall

Edmund Gall

  • 156 Posts
  • 55 Reply Likes
Hi Peter! The only thing I can think of is whether it happens after you've chosen to Edit in Photoshop from LR, and chosen the option to Edit Original. Sometimes, after you've saved changes in PS and the changed image returns to LR, LR fails to apply some recent Develop changes (or edits). To reslove, you have to open the History Panel in the Develop Module for the affected image and click on the most recent LR edit at the top of the list shown there.

Hope this helps...
Photo of Ruby k

Ruby k, Employee

  • 25 Posts
  • 17 Reply Likes
Hi Peter, Thanks for taking time out to report the issue. Can you please provide following info for us to analyse the issue further
1) System Info(Mac or Win , OS info)
2) Lr Classic Version you are using
3) As Edmund has said in above comment , it happens in a specific case? is it same for you also?